Re-launching HTML5 Course --No Audio

I'm trying to help a client with an issue she is having with Storyline for iPads. 

The course is published to AICC.  It is narrated and slides do not advance automatically.

The first time you launch the course (HTML5) you hear the audio; however, if you do not finish and then re-launch the course with your iPad, the audio does not play.  Not good . . .

I've verified the issue with her .story file and re-publishing the course in the LMS, both as AICC and SCORM 1.2. 

I'm using Storyline Update 2 and my iPad2 is on iOS 6.1.2.

If I publish the course to the web and then access the content from my Amazon S3 account with my iPad2, I see the same behavior.

Now here's the kicker, I load the course in the SCORM Cloud and there's never any narration.

Any ideas why the missing narration?

67 Replies
Gerry Wasiluk

Okay, I got permission from my client and will be submitting her file in a new support ticket.

I also created a quick test course to try and duplicate the issue playing the course as HTML5 on my iPad.  I did re-create the issue exactly with my new test course.

Another weird thing (with both courses) is this--the first few times I re-launched one of the course after quitting early, the resume did not work.  I was not prompted to re-start on re-launch even the course is set up for that.  But the audio always played.

However, after a few launches the resume "finally kicked in" and then the audio stopped.

Gerry Wasiluk

Hey, Pete!  Just got word from support on this:

"We were able to duplicate the issue you reported. Unfortunately, we were unable to determine a workaround.

We have reported this issue to our Quality Assurance team for their review. I cannot offer a time frame for when or if this issue will be addressed."

I'd like to think this is a pretty serious bug, one that should get addressed ASAP, IMVHO.

FYI:  I have a client who is readying a major sales training initiative to their external distributors and customers who is not going to be too happy with this.  The training will be run through their external-facing LMS and many of their learners use iPads.

This client--a major user of Articulate software--has been bit by a couple of other Storyline bugs.  Their confidence in Storyline is beginning to get shaken.

I have one workaround for them on this issue but they are not going to like it.  Have the main content of the course outside of the LMS--that way the Articulate Mobile Player can be used.  Then just have the final quiz in the LMS.

Of course, those not on Apple devices and without Flash are still left in the dust . . .

Peter Anderson

Thanks, Gerry, and I'm really sorry about the inconvenience. As suspected, this is related to another issue that's recently come to our attention. 

As of this morning, we're still testing internally and trying to get it worked out. Justin or another engineer will be sure to keep you updated via your case emails, and I'll follow along as well. 

Thanks for for all of the information you've provided - we'll be in touch soon!

Marco Bennardo

Hi Peter,

I have the same problem with iPad iOS 6.1 and Android 4.2 on HTML5 mode . When i resume a course the player lost all audio of the slides.

I'm using Storyline Update 2 and the course is published as SCORM 1.2 in a LMS.

Republishing the content without the resume lightbox question the audio go right.

Do you think to solve this bug on next update?

Thanks

Marco

Peter Anderson

Hi Marco!

Yep, it looks like we're going to be able to get this one fixed before the next update; we just don't have an exact date for when that update will be released, but I suspect it's not too far away. 

The best way to learn about our update releases is through our Word of Mouth blog. 

Thanks, Marco!

Marcia Marcia

Peter,

I am also testing Storyline delivery on mobile devices for my client and am having the same problem as described above. Will updates be available for those using the free trial?

I have to show my client how Storyline will do what they want/need before they invest in buying it.

Thanks,

Marcia

Gerry Wasiluk

Peter Anderson said:

Welcome to the community, Oscar

Unfortunately, there isn't an easy workaround at this time. It appears that something changed in the iOS update from 6.0.1 to 6.1.2, causing this to occur. 


Interesting . . .

Thanks for keep us informed, Pete, with what information that you can provide. 

Gary Baldock

So glad I've found this post, this issue has been bugging me for weeks!

I'm also experiencing the no audio on resume when a course is run in a HTML5 browser. The only work around I've found is to switch off the resume prompt in the player properties. The learner will lose any progress they have made but the audio will play. This is not ideal as I have a client who is desperate to get their course released. We have had to create duplicate copies of each module, a standard version for Flash enabled devices which will resume and another for HTML5 that will not resume.

My client is now having issues with the HTML5 course tracking back to their LMS (hosted by Learn Upon).

I really hope the fix in the next update isn't too far away. As with Gerry's client, mine is also losing faith in Storyline which is a real shame as its a fantastic piece of software with so much potential.

Gerry Wasiluk

Gary Baldock said:

I really hope the fix in the next update isn't too far away. As with Gerry's client, mine is also losing faith in Storyline which is a real shame as its a fantastic piece of software with so much potential.


I think the great way that Articulate has chosen to immediately jump on this issue has really helped my client.  Pete being able to provide what info he can has also helped.  Nice to be able to give an update to the client that things seem to be moving in the right direction.

Two other issues bugging the client have turned out to be more LMS issues, ones that Articulate cannot work around.  So the LMS is getting more a black eye there.  So I believe the client is feeling a lot more assured.

Sam Carter

Peter Anderson said:

The best way to learn about our update releases is through our Word of Mouth blog. 


Pete,

Are you saying that Storyline won't automatically prompt for this update meaning we will have to scan all the Word of Mouth blogs entries looking for a fix?

How about a sticky post in this forum for major announcements like bug fixes coming in point releases?

Sam

Peter Anderson

Sam Clark said:

Are you saying that Storyline won't automatically prompt for this update meaning we will have to scan all the Word of Mouth blogs entries looking for a fix?

How about a sticky post in this forum for major announcements like bug fixes coming in point releases?


Hey Sam, thanks for asking. I'm actually having a hard time remembering if our last update (Update 2) triggered the Check for updates option. It should have, though it might've been a day or two after we actually rolled out the update. I'll look into it and make sure that our next update does in fact alert users when they open Storyline that a new version is available. 

And of course, as soon as I get the green light, I'm always eager to share the news right here in our forums. I'm sure the Twittersphere will light up as well. 

And I like your idea of a sticky post - think I'll mention that to the web dev guys

Have a great weekend, guys!

Peter Anderson

Sam Clark said:

Peter, 

Any chance some of the other HTML5 bugs might be fixed along with the audio on resume issue?  There's the animations won't sync with audio in layers issue for example.


I won't have the full comprehensive list of all the fixes until it's actually released, but the guys have done a great job of fixing A LOT of bugs. It's an impressive update. 

As for the specific bug you mentioned, it looks like it's been marked as a top priority for the next update, so fingers are crossed that it will be included.