SL2 & SL360 "Restricted" Menu Navigation and Next Button - Solution / Workaround

Many developers are having an issue with the new "restricted" menu navigation logic in SL2.  I have come up with, what I think is a very quick, simple and viable solution.  To re-cap the issue:

  •  In SL1 the Menu Navigation options include “restricted” which allows learners to view the current slide and any slide they've previously viewed, but not use the menu to jump ahead or skip over slides.  This only restricts the learners' ability to click on menu items to navigate. If the slides included a Previous or Next button, users can still be click those to freely move forward and backward in the course at will.  Content developers could add triggers/variables to control the previous/next buttons, as they saw fit.
  • In SL2 the Menu Navigation “Restricted” logic was changed.  The restricted option still allows learners to view the current slide and any slide they've previously viewed, but not use the menu to jump ahead or skip over slides.  However, this now also disables the Next button and does not allow users to advance forward until the timeline ends.  Triggers/variables do not work to over-ride this logic change.

Here’s what I have come up with:

  1. Create your .story project and set the navigation menu options to “Free”.  This will ensure that the next and previous buttons are not restricted.  (Don't worry, we will adjust the menu navigation itself in a bit).  If needed, go ahead and create triggers/variables to control the previous/next button navigation as desired.
  2. Publish your .story project.  Go ahead and “zip” if the course will be uploaded to an LMS.
  3. In the “publish successful” pop-up window, click “OPEN” to open the Storyline output directory.
  4. Double-click and open the story_content folder.
  5. Open the frame.xml file (this can be opened with Notepad)
  6. Find and replace the following:
    <option name="flow" value="free" />
    with
    <option name="flow" value="restricted" />
  7. Save and close the frame.xml file.
  8. Launch and play your course.  The navigation menu is now restricted, but the previous/next buttons can be used at will.  (Any triggers/variables that were added to control the previous/next button navigation should work as developed.)

If uploading to an LMS, you have a couple more steps.

  1. In the file directory, right-click and "copy" the modified frame.xml file.
  2. Navigate to the story_content folder in the ZIPPED file.
  3. Right-click and "paste" (replace) the modified file here.  You can now upload to your LMS.


This seems kind of tricky, but it is actually very easy!  And once you’ve done it a couple of times, you will see that it literally only takes a few seconds to do!

Hope this helps,

Bobbi

Addendum for HTML 5 (added 10/11/2016)

If publishing to HTML 5, the frame.js file must also be changed.  This can be done by following the below steps.  (NOTE: These steps must be done prior to uploading to LMS, if launching through an LMS.)

  1. Open the frame.js file (recommend opening with Notepad)
  2. Find and replace the following:
    |free|
    with
    |restricted|
  3. Save and close the frame.js file.
192 Replies
Wendy Farmer
Lindsey Hillman

Hi Wendy, thank you for your time!

I think we have figured it out now - and it might be useful for others. We obviously don't have the software on our PCs to recognise that there is a .js file. So I tried to open the only other file that was different - the notepad.exe.

When I opened and amended the script, it asked if I wanted to save my changes to my .js file, so it obviously is the file I'm supposed to edit, but in a different guise!

Michael Hardin

After looking at your screenshot, I see the root cause for the confusion.  In the "Folder Options" (in "Windows Explorer" > "Tools" menu > "Folder Options" > "View" tab) you have "Hide extensions for known file types" checked.  This means any file type associated with a program doesn't show the extension, in this case ".js".  The reason you see "notepad.exe" under the "Type" column is because on your system ".js" files are associated (set to open) with NotePad.  If you go into the "View" settings of your "Folder Options" and uncheck that option, you will always see the file extensions.

Dave Cox

Hi Caitlin,

When you right click on the file, and select open with, you should see a list of files that Windows thinks it can use to open the file. If notepad isn't in the list, you can use "Use default program..." to navigate to the notepad.exe file. The notepad file is usually in your windows system32 directory.

An easier way to get the file into notepad though is to open notepad, and then just drag and drop the file into the notepad window.

You might also have trouble editing this file if you are attempting to edit the version in the zip file. You can navigate into the zip file using windows, but opening these files doesn't work the same as when they are in a regular folder. If this is a case, try editing the file in the regular folder that storyline creates, and then drag and drop the file into the zipped folder to overwrite and replace the original.

Alyssa Gomez

Hi there Ros,

I don't see that this has been reported anywhere else in the forums, so I really appreciate you bringing this up here. I created a quick sample file with restricted navigation, and it looks like you cannot swipe next or previous, even when the timeline ends. You definitely should have the option to swipe once the timeline ends, so I'm going to share this with the team so we can get it reported as a potential software bug. I’ll let you know as soon as we have an update, and thanks so much again for letting us know about this!

Ros McNamee

Wow Alyssa, thanks for researching into this! I tried going into the xml file myself but nothing I tried worked. Seems it is just completely disabled. It would be great to get this feature working asap, as it would really help ongoing projects I am working on that are heavily reliant on mobile. 

I appreciate you contacting the team and hopefully we will see an update soon fixing this bug :)

Carrie Albin

First off, thank you Bobbi for the excellent workaround.  It was definitely a lifesaver!

Has anyone had any success using this workaround in Storyline 3?  I'm assuming if the workaround works for Storyline 360 it should work for Storyline 3.  However, I just upgraded a Storyline 2 file to Storyline 3 and it appears the HTML5 version of the course doesn't restrict the menu anymore even though I changed the frame.xml file and the frame.json file.  I'm assuming the frame.json file is the same thing as what was the frame.js file that I had to change in Storyline 2.  I don't see a frame.js file when publishing in Storyline 3 but I do see a frame.json and that is the other one that I changed.  But when viewing either in the LMS or just on the web with the HTML5 link the menu is completely free and not restricted.  Anyone else having this issue?  

Dave Cox

Hi Carrie,

In Storyline 3, you can make the same modification to the frame.js file to restrict navigation as was made in Storyline 2. If you are publishing the HTML5, there is an additional frame.js file that need to be updated in the same way. This copy is located in the html5/data/js folder. 

Just change "free" to "restricted".

You don't need to modify the .json file.

Carrie Albin

Of course after I posted I was able to figure it out.  ;)  It seems that Storyline 3 puts the frame.js file in an HTML5 folder.  So in order to do this workaround correctly in Storyline 3 you need to change the frame.xml file in the story_content folder and the frame.js file in the HTML5 folder.  That seemed to do the trick.  I am publishing with the setting Flash with HTML5 fallback.  

Ashley Terwilliger

Hi all,

Great news!  We just released another update for Articulate 360, and included a few important fixes and new features that you'll see in the release notes here.  

The item you may be interested in is how when you restrict or lock navigation, you can now choose whether it impacts just the course menu or also disables the Previous and Next buttons. And you can use triggers to override restricted navigation for individual slides.

Just launch the Articulate 360 desktop app on your computer and click the Update button. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly. 

Ashley Terwilliger

Hi Wendy,

Could you share a copy of the course here so that folks could take a look at what you've got set up? I know there were a few mentions earlier in this discussion of it not working in SL3/360 - but then I believe that Bobbi did some updates (hence the updated discussion title).  

We did also push out a change to SL360 (it's targeted for the next update of SL3 as well) that changes how the restricted navigation/next button behavior. You can read more about that here.