SL2 Right-Click Trigger Fails

Hello. While this issue has been reported over two years ago, I have not been able to find a fix or workaround for this problem. The right-click trigger is broken in some cases. For example, if you use a right-click trigger to show a layer on a slide, it fails for me consistently. I have uploaded a test file to Tempshare here:

http://s3.amazonaws.com/tempshare-stage.storyline.articulate.com/stp19bn77g1tpgm1c9a10mv1b1315164/story.html

Slide two is setup to show a layer on right clicking the circle. Please help test this and post your results. I believe this to be a bug and want it finally addressed. PS. Right-click functionality also fails to work in some browsers when run locally. It was reported that running on an LMS or webserver will enable right-click functionality to work, however, it still fails for me. Given that this issue is over two years old now, I would really like this addressed and a permanent solution achieved.

99 Replies
Joyce Hensen

It's working for me in the LMS, too.  When I previewed the scene with Right clicks in preview mode, it worked great, too.  However, when I published it and then previewed the published file, nothing happened on right click.  I took a chance and uploaded it to the LMS.  In the LMS it worked fine.

Ashley Terwilliger

Hi Debra,

Did you install the latest update (Storyline 2 update 7) and republish the course? If so, and you're still seeing the issue can you look at testing the course in another web browser or clear out the cache/history of the current browser to ensure it's reloading the course vs. accessing the cached copy? 

debra corda

No, I haven't. I will contact my support desk. I am not able to update or
install. I am a little afraid. When I updated Storyline 1, it crashed my
computer. I had Articulate and my support desk involved. No one could
resolve the issue. I had to get a new laptop. I know this was probably a
one off, but you can probably understand why I am afraid of updates to
Storyline. Thanks!

Ashley Terwilliger

Hi Debra,

I can certainly understand, and involving your support desk would be ideal then. Are you using Storyline 1 or Storyline 2 currently for this issue? The release notes I linked to were for Storyline 2, which had a fix for the right click trigger issue but I don't see that it was an issue for Storyline 1.   You'll see here it's for the right click on the base layer. 

If you want to share the .story file I can publish it under the new update so that you can confirm if that works for your situation. If you want to post it here you can do so using the "add attachment" button or you can send along to me here. 

Eoin Conway

Hi there,

I had experienced an issue with right-click not working and this was corrected by the software being updated. However I find now that when I publish to web, the right click function will only work on my computer if I open the folder on my desktop.

If I move it to a network folder so others can view it, right-click doesn't work for anyone, including me. I would need to put the file on a network folder in order for my UAT participants to complete their activities.

The HTML5 files works but not everything looks the same as I designed it so it's not suitable for UAT.

Is anyone else experiencing this?

Thanks,

Eoin

Ashley Terwilliger

Hi Eoin,

Are you publishing for web or LMS? If so, you'll want to upload to the web server or LMS to test it and share with other users as viewing the web published content locally you may be running into issues with that set up. 

If you need to place within a network folder, have you looked at publishing for CD and then instructing users how to download and play those files? 

Sales Framework

Hello, 

I'm still unable to get the right-click function to operate correctly on a hotspot question. 

When I use the "submit answers on click", any click in an incorrect location will result in the Try Again or Incorrect feedback layers. This is perfect, and working as designed. 

As soon as I change to "submit answers on right-click", the ONLY action that will result in a feedback layer is correctly right-clicking on the hotspot. How can I get the incorrect behavior (right-clicking anywhere else) to show the feedback layers appropriately?