Vimeo videos not loading

HI...

I'm trying to use the vimeo videos in Storyline. If a use a Youtube video it works fine but when i put a video video (with the embed code copied from vimeo) in the preview does not load and online, after a while, the video objects shows a "page not found" or similar.

May be the embed code is not fine to the articulate or something like that?

Any suggestions to solve this?

Thanks

31 Replies
Concetta Phillipps

I know this thread is older, but I'm actually getting an error when I try to put the embed code in as a video from Vimeo that the video cannot be embedded using the link I'm given from Vimeo's embed settings.

I can't put the exact link from Vimeo in here as the content is confidential, but the format of my link is this:

https://player.vimeo.com/external/VIDEONAME.sd.mp4?s=VIDEOID&profile_id=999

Its for a private link on Vimeo, so it does not use the normal display on Vimeo.com and only brings the video without the player and branding. 

We don't normally have an issue with this in Articulate Presenter, so I was surprised to find when I upgraded to Storyline 2 that it would have an issue with the Vimeo links. 

So I tried the suggestions here to use the video link as a web object, but then the final module requests a download of the video from Vimeo, not playing the video. 

Any thoughts would be most welcome. 

Concetta Phillipps

I don't think it should have problems accessing it - I just tried it with another private video and it has the same issue in Storyline 2, but when I try it in Presenter it works just fine. 

This is the error message: "A video cannot be inserted from this embed code. Verify that the embed code is correct and then try again."

So I made a completely innocuous video going over the Vimeo settings - here's the link: https://player.vimeo.com/external/233033976.hd.mp4?s=5fe278de22d05a67dc92cc4bad8464cb06177691&profile_id=174 . Its set up the same way as all of our other videos with the same embed settings, and the same video link. 

 

Ashley Terwilliger

Hi Concetta,

That link you shared works when I use the "Insert Web Object" option. The embed code would look something more like this ( a random one I grabbed from Vimeo's site):

<iframe src="https://player.vimeo.com/video/230747958" width="640" height="360" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
<p><a href="https://vimeo.com/230747958">Scotland - Lochs, Mountains &amp; Light</a> from <a href="https://vimeo.com/stocker">Adam Stocker</a> on <a href="https://vimeo.com">Vimeo</a>.</p> 

You'd then use the option to Insert Video - from Website.

 I published this version with your video on the first slide and the video link above on the second slide. Take a look at that one and let me know if you have any questions. 

claudia lópez

Good morning,

I have a small problem and I hope you can help me with it. I need to hide the advance controllers of a Vimeo video embedded as a web object, setting controls=1 parameter generates an error for Chrome, but it does allow me to view it in Internet Explorer, in this case, also deactivating the play and pause controllers ( for YouTube videos controls=1 parameter, it hides all the controllers, but allows the play and pause action from the keyboard and the autoplay automatically starts the video). Is there a compatible parameter for all browsers that do what I need, hide video advance controllers, let play and pause active and auto play for embedded Vimeo videos as a web object? This is the address I am adding with the following parameters:

https://player.vimeo.com/video/3499xxxx?autoplay=1&loop=1&title=0&byline=0&portrait=0&controls=1

Thank you.

Vincent Scoma

Hey Claudia,

Thank you for reaching out! It looks like Katie responded to you here, and she had a few questions for you. 

One thing I wanted to mention is that you will want to be sure to use the Embed Code that Vimeo provides. You can adjust the Embed Code which will allow you to apply those settings. As Ashley mentioned, the embed code would look something more like this:

<iframe src=“https://player.vimeo.com/video/230747958” width=“640" height=“360” frameborder=“0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
<p><a href=“https://vimeo.com/230747958”>Scotland - Lochs, Mountains &amp; Light</a> from <a href=“https://vimeo.com/stocker”>Adam Stocker</a> on <a href=“https://vimeo.com”>Vimeo</a>.</p>