NEW in Rise: Export for Translation

Jun 13, 2018

If you need to create courses in multiple languages, you’re going to love this new Rise feature. It allows you to export your course text to an XLIFF file* and then reimport it once it’s been translated. Like magic: all your text is replaced by the translated text. It’s that easy!

NEW in Rise: Export for Translation
*XLIFF files are a translation industry standard, so if you’re working with professional translators, then you shouldn’t have any issues. But what if the translations are being done by a fellow coworker or friend? No problem! If you do a quick Google search, you’ll find a ton of free tools that allow you to easily edit XLIFF files.


183 Replies
Ashley Terwilliger-Pollard

Hi Jenna, 

I haven't seen text appear bold after translation, was this on the entire course or just the labels? 

Also, for your Chinese labels, it sounds like they didn't update or did something else happen like the text appeared oddly? If you could share some screenshots or more detail about the steps you went through that'll help us track it down. 

Kenneth Farrall

Hi Ashley,

I'm employed at the vendor that was on this project and I can add a bit more information on the problem. For the Chinese label issue, I was trying to upload a translated XLIFF file for Chinese labels and got the following error message: "Error: Incompatible format." We uploaded similar XLIFF label files for Polish and Portuguese without any issue.

For the Polish, it's a problem we have also seen in Storyline 360. In the case with Rise, it happened when special formatting was used, such as for a quote. I have attached an example. Changing the special formatting from Statement C to Statement D fixed this issue. There were 3 or 4 instances of characters being individually bolded throughout the course.

Ashley Terwilliger-Pollard

Hi Kenneth,

Thanks for sharing some more details. What translation tool were you using for the Chinese Labels? We've heard some similar issues using SDL Trados Studio 2017 and MemoQ.

For the bold fonts, it seems from that image it's only on the special characters? Were you applying special formatting, or relying on what Rise adds based on the block type? When you've seen the same thing in Storyline, what format was applied there? I'm glad switching the statement type fixed this, but I'll take a look at the statement C setup too. 

Kenneth Farrall

Hi Ashley,

For the Chinese labels we were indeed using SDL Studio 2017. Studio and MemoQ are market leaders in the CAT tool space.

Regarding the bold fonts, we did not add any special formatting. I also noticed that the bolding appears on some, but not all, special characters. The problem we encountered in Storyline also occurred in blocks of text without special formatting. In addition to being bolded, characters appeared as different sized fonts in the same word. The problem in Storyline was intermittent and not always reproducible. Our experience there was that files might look fine on our side, but if another person opened the same file they might encounter these issues, or we might encounter them after executing an import of translated content. 

I have added two additional examples of the Polish bolding in Rise.  Example 2 uses the Quote B style. Example 3 is a little different, in that case, it seems that the Rise display system is not properly reading the close font tag. Bolding should end where the comma is in the first sentence, but it just continues to the end.



Ashley Terwilliger-Pollard

Thanks, Kenneth.

I know our team is looking into the issues with SDL Studio 2017, so I'll keep you posted on that here.

Thanks for the images in Rise too, I tested out myself with some random Polish text (courtesy of Google Translate!) and I didn't see bold text, but the accented characters were actually quite smaller. Can you let me know what font you're using in Rise? I'll share both examples with my team so that they can take a better look! 

Yannick C


We are having the same issue mentioned by Cameron Campbell and others. When our translation agency opens the XLIFF file in Logiterm (by Terminotix), the text has HTML formatting mixed in with the text. The same is true if you use the free tool from Brightec as recommended.

Hopefully this can be addressed as it's not feasible to translate when the HTML tags are mixed into the text.

Kenneth Farrall

Hi Ashley,

Thanks for this suggestion. I had not tried it before. If I understand correctly, although Rise has the Merriweather font available (for example), it's not complete and lacks non-Latin characters. This would certainly explain the problems we have been having. I followed the process with Merriweather font and created a custom font called "Merriweather Full." Unfortunately, it didn't solve the problem. Would you suggest trying this with other fonts? 

Kenneth Farrall

Hi Ashley,

I created a new custom font that includes Latin, Latin Extended, Cyrillic, and Cyrillic Extended and called it Merriweather Complete. Unfortunately, although the behavior changed slightly, the letters with diacritics still show differently. This time they are smaller, rather than bold (see attached file). It's my understanding that standard Polish characters with diacritical marks are technically part of the "Latin Extended" family, so it may be worth trying to make a font with just that and see if I get a different result, but I'm not sure how the mere presence of Cyrillic in the font set should impact anything.

Any further thoughts at this point?

Shaun Prinster

Here's another issue for you. We've exported a number of courses and we've been able to translate with no problem. But now, we have a course that's giving us problems. When we tried to import the translated xliff, we get a message that says:

"Import failed: Check formatting or re-export translation."

Just to make sure we hadn't changed something during translation, we even tried exporting the xliff file then importing it right back into the course without changing anything and we still get that same message. So, it appears that the xliff file is formatted incorrectly upon export.

Are there any characters we should avoid using that might be causing problems reading the translated file back in to the course? Any other ideas what might cause this?



Leslie McKerchie

Hi Aaron,

What links are you trying to access?

I know in the initial post that Kelly shared above, that is an image of what you will see within your Rise course. I wasn't sure if those may have been the links you were trying to click on.

Just let us know what you need some help with and we'd be happy to help you out.

Crystal Horn

Hey everyone!  I’m happy to let you know that we just made translating content in Rise even better.  You can check out the release notes here.

We fixed an issue where XLIFF translation contained components that some translation tools couldn't process.

The new version of Rise is live now, so just simply export your XLIFF translation again and let us know how your tool handles it!

Irina Poloubessov

Dear Crystal,
We tried to test the .xlif with 2 fields translated (not all of them) and got the failure message when importing the translation back. (please see attached)

UPD - we also tested it with all fields completed fully. Still cannot import.

What causes the failure?
Thank you!