RISE Published to SCORM 2004 - At quiz completion message "Fatal error has occurred, communication with the server has been lost" appears

Jan 11, 2017


Has anyone come across this issue when Publishing RISE courses to SCORM 2004 v4 were it looks as though the quiz results wont post to the LMS?  We don't get the error with SCORM 1.2 (using 1.2 we don't get the fail :( but it post the result), it appears when we use SCORM 2004 V4.

Not sure if it's related but we also find that you sometimes can't click the next button in a quiz to progress (nothing happens).  Clicking the previous lesson then back to the Quiz remembers where you were at in the quiz and takes you to the next question.  At the end of the quiz you get the fatal communication error message.

FYI: I've tried accessing the course on the latest Chrome and IE Browsers and have used various web connections just to make sure it wasn't a dropped connection.   I've also tried on Win7 and 10 (Org still uses 7).

And we have our LMS provider PeopleStreme trying to replicate the issue.

Any ideas or suggestions around how we get around this would be appreciated.



9 Replies
Ashley Terwilliger-Pollard

Hi Lionel,

Well "fatal error" never sounds fun - so let's get to the bottom of this ASAP! Did you already look at testing this course in another LMS environment to help rule out anything Peoplestreme specific? We like to use SCORM Cloud as a testing platform and the article here (although prior to Rise) will help with the steps to go through uploading content there to properly test. 

We'd also want to take a look at the LMS export in question, and it's often easiest to do so in the form of a support case so that we can work more one on one and your information isn't here in the public forum. You can open up a new support case by visiting this form and you'll see the option to upload the published files. That way we can test out the results not being passed and the odd next button behavior you are seeing.  Once you upload it there, just give me a shout and I'll be able to follow along as well so that I can keep this forum updated in case it's something we're able to determine will help out other users! 

Marc Koenecke

Thanks Ashley.  

We are finding that the issues that we are having appear to be intermittent.  Not sure whether these are system configuration/network setup issues (on our end) or related to the LMS - They cannot replicate the error.

I will look at trying SCORM Cloud as we need to rule the LMS out or in for that matter.

I'll update this thread and raise a Support ticket if SCORM Cloud generates the same issue.  And will keep you in the loop as well :). 

Marc Koenecke

Update:  I published one of our more detailed RISE courses to SCORM Cloud and it worked as it should.  Articulate Support also tested it and found not issues.  We're still finding that we get a Fatal error "connection lost with the server" after course completion (when we close the webpage after viewing the Thankyou page), but now the values are being written to the LMS, so the course result is available.  Our systems team are working through the issue with PeopleStreme however they're unable to replicate the issue.

If anyone has any ideas I'd appreciate it.

FYI:  We are using IE11 to do the testing on Windows 7 machines.


Marc Koenecke

Update:  The issue appears to have been resolved.  Data is being is now able to be written back to the LMS - this does appear to have been an LMS issue.  Thanks to the Articulate Support team for testing the SCORM file for us.  The only frustration we still have is the fact that our organisation is using IE11 which effects the way components appear on the screen, but the data issue seems to be resolved :).

Thanks Ashley.  I'll post details around what they did to fix the "Fatal error" at course completion once I've been briefed by our HRIS team.

Ashley Terwilliger-Pollard

So happy to hear that Lionel and thank you for coming back to update us here. We've seen some other issues with IE11 and specific LMSs, more in terms of the way it's launching so you may want to take a look at the discussions here just to keep yourself up to date on some of the oddities surrounding IE11 (essentially these users are seeing it forced into compatibility mode and showing IE7...which isn't going to work great with HTML5 content.) 

This discussion is closed. You can start a new discussion or contact Articulate Support.