Error when uploading SL360 content to PeopleSoft

Hi - have a client who uses PeopleSoft LMS. When they try to upload content created/published in SL360, they get an error: Invalid IMS Manifest File. Please load a project with a valid SCORM 1.2 compliant IMS manifest.

I have tested this file in SCORM Cloud and it is SCORM 1.2 compliant. Can anyone give tips on how to upload Storyline content to PeopleSoft?

Thanks, Steve.

27 Replies
Steve Jones

I reached out to support and got this response:

From the looks of your screenshot, it appears you're experiencing this issue when uploading a SCORM 1.2 published file to PeopleSoft Enterprise Learning Management (ELM). Happy to help you get to the bottom of this.

Can you please confirm if the following steps work? What you're experiencing could be related to an existing defect with the following workarounds.

1. Publish the course using SCORM 2004.

2. Downgrade to Storyline 360 Update 11. Follow these steps to install the previous version of your software:

2.1) Open your Articulate 360 desktop app by clicking the icon in your computer’s system tray (by the clock) or using the shortcut on your desktop.

2.2) Hover over Storyline 360, click the drop-down arrow that appears, and choose the uninstall option.

2.3) Download and install the previous version here: http://tinyw.in/ab1L

2.4) To open Storyline 360, go to your computer’s Start menu and select it from your list of apps. Or, create a shortcut for it on your desktop or taskbar. (You won’t be able to open it from your Articulate 360 desktop app. It’ll show an Update button rather than an Open button while this older version is installed.)

My client has told me if SCORM 2004 worked or not so haven't tried the remaining steps yet.

Ashley Terwilliger

Thanks, Steve for sharing that update here with us.

I know that Update 11 is what works for folks using this LMS, but we'd advise anyone else running into a similar issue to connect with our Support team first so that we can help you confirm it's the same thing. I'd hate for someone to be on a much older update than necessary (we're currently on Update 17). 

Leslie McKerchie

Hi Rena,

I took a look into the case that Steve worked on with our team and I do not see any additional information shared. We do have this as an open report.

Publishing to SCORM 2004 is also a note we also have listed, so good to know that this is working well for you as well.

You should now be subscribed to this forum thread and we will be sure to share any additional information that we have here with you.

Kim  Brown

Hi, I'm getting the error trying to publish a Studio 13 (cloud) course.   PeopleSoft ELM is complaining about a duplicate tag in ims.manifest.

 The oracle peoplesoft error is: A software fix is applied to fix the content upload error due to a duplicate tag “identifierref” in a SCORM1.2 content file.

I'm trying to locate the duplicate tag and see if removing it helps. the bug is Bug 19941996 : ELM 9.2: SCORM 1.2 CONTENT ERROR AFTER UPLOADING THE CONTENT.

Katie Riggio

Hi there, Kim. Happy to help!

If you see this error when uploading to the PeopleSoft LMS, let's check out how the same course behaves in SCORM Cloud (a free industry-standard tool for testing SCORM output). I'm also curious to know if publishing to the SCORM 2004 format helps resolve this error.

And if you're able to share the source file here, we'd love to test it and share our findings with you. Keep us posted either way!

Katie Riggio

Appreciate the update, Kim!

For next steps, I would touch base with the LMS team/admin to let them know that the file uploads without any errors in SCORM Cloud. They should be able to give better insight into what the PeopleSoft LMS is trying to tell us. If they're able to provide some helpful information that points to an issue with Studio 13's output, please let us know.

We'd love to help test the file and are ready to help! 

Greg Mellang

We reported this issue earlier this year, shortly after the v12 upgrade.  What I find odd, is that the manifest file from RISE uploads to PeopleSoft ELM without issue.  I have contacted Oracle, and they have not had any changes that would have caused the error message.
I have uploaded manifest files from Adobe Captivate, Camtasia Studio, and Lectora without issue.

Apparently, there is a hidden character in the manifest file template, but for the life of me, I cannot see where it is that causes the error.

Our workaround is to edit certain rows of code using the v11 manifest (last known working version) with the rows from the new manifest, and it has been working so far. But we have a lot of non-coders, and adds to our publishing time.

Leslie McKerchie

Thank you for popping in to share the details of what you are experiencing as well Greg. 

You mentioned that you reported this earlier and I'm not seeing anything similar on our side, so does that mean you reached out to PeopleSoft? 

We are tracking a similar report and I've added this conversation so that we can share any updates with you here.

Greg Mellang

Good afternoon,
I am still receiving the "Invalid manifest" error when uploading to PeopleSoft ELM for SCORM 1.2 content.  I've published RISE without error, and published SCORM 2004 without error.

Any clue how we can get this resolved? I have just updated 360 to the latest version.

Thanks and have a great day.

~Greg

Alyssa Gomez

Hey Greg and Rena,

So sorry you ran into this. Our team is still investigating the issue where Storyline 360 courses published to SCORM 1.2 will not upload successfully into PeopleSoft. 

As a workaround for now, you should be able to successfully upload SCORM 2004 output. 

We'll keep you posted as we make progress on this bug!

Ashley Terwilliger

Hi Tom,

Thanks for reaching out here, and I'm sorry that you're still having trouble. When you've published for SCORM 2004, what tracking/completion method were you also using? In the issue our team is investigating the files wouldn't upload at all using SCORM 1.2. I'd be curious to know if you've looked at enabling LMS debug mode to see if the data is being passed correctly to the LMS or if it's not being interpreted by the LMS correctly. Our Support Team can help you dig into those reports if needed! 

Leslie McKerchie

Hi Justin,

Thanks for contacting us and sharing that you're running into an issue as well. 

I'm not seeing where we've been able to nail down a resolution from our end yet, but I do see that the issue is only affecting SCORM 1.2 published output. Have you tried publishing to SCORM 2004 format?

This conversation is linked to the report so that we can share any updates with you here.

John Carter

You may not like this answer.
I went back and forth with Articulate and my IT department for two months before being able to resolve this issue. The final determination was that I had to downgrade my version of Storyline to 3.11, ….which is 3(?) years old now,...... not supported any longer...... and I don't even think you can download it anymore. I live in panic that Storyline will somehow automatically upgrade and I will no longer be able to do my job. (I am ONE person creating training for 15,000 employees!) 3.11 is the last version of Storyline that will produce an imsmanifest file that plays well with PeopleSoft. I will include a screenshot as an attachment of my version number. This has been quite frustrating as I see (and get) new functionality emailed to me that I cannot even open. I feel like a kid in a candy store with no money.

Fortunately for myself, my company is dumping PeopleSoft and WorkDay is coming on the scene October 5. I am looking forward to being able to use the latest version of Storyline. It is my intention to forgo SCORM when this happens and go to xAPI.

Justin Vaughn

Hi! We were actually able to get it figured out! Like John mentioned (and as this post mentions) I had to downgrade my version of Storyline. We're doing final tests now but everything seems to be working.

Since I downloaded Storyline recently, I had the latest version. Once I got in contact with Darrell from Articulate Support, we figured out that the problem may have been with our LMS because the course was working in the SCORM Cloud. I was then informed by our PeopleSoft rep that our LMS wasn't up to date and that may be why my course wouldn't upload. So I downgraded to the version from March 2020 and it ended up working. 

Thanks for the feedback!!