Storyline course randomly getting "stuck"

Hello,

I'm finding that as I continue to develop my skills with elearning, and my courses become a little more complex, I'm having problems with the published courses. I just released a course and about 40% of users are getting stuck somewhere in the course. They say that no matter what they click the course will not advance. The rest are able to complete it successfully. This course does have a few small "try me" simulations. At first I thought it was user error, but that would be over 200 users so far that have had an issue. Any thoughts?

55 Replies
Brian Dennis

The Articulate team might find system information (browser, operating system, etc) helpful. How many of the ~100 people are using IE11, Edge (Windows), Chrome for example. Articulate posts the supported system configurations. I've bookmarked so I can share with clients when starting new projects.

https://www.articulate.com/support/storyline-2/system-requirements-for-articulate-storyline-2

 

Ashley Terwilliger-Pollard

Hi Amy,

For Sarah's previous issue the steps she was directed to go through were the following:

1) Upgrade Adobe Flash Player here: http://www.adobe.com/go/getflash 

2) If your LMS requires Java to be installed on the client computers, be sure the correct version of Java is installed and enabled for your browser. Java can be downloaded and installed here: 
http://java.com 

3) Clear your browser cache. You can do this in Internet Explorer by going to Tools > Internet Options > General > Temporary Internet Files. Select Delete Cookies and Delete Files. 
4) Also in Internet Options, on the Security, Privacy, and Advanced tabs, reset everything to its default settings. There is a button on each tab to reset defaults. 
5) In Windows Vista / 7, go to Start > All Programs > Accessories > Run.  In Windows XP, go to Start > Run.
6) Copy / paste the following line of text (depending on your operating system) into the Run dialog box. Click OK, and delete the entire contents of the window (folder) that opens.

Windows Vista / 7:
"C:\Users\%username%\AppData\Roaming\Macromedia\Flash Player\#SharedObjects"

Windows XP: 
"C:\Documents and Settings\%username%\Application Data\Macromedia\Flash Player\#SharedObjects" 

7) Close all browser windows for the changes to take effect, and then test your content again.
 
As Brian shared, there are particular supported browsers for Storyline content, and you'll also want to confirm if your LMS has particular supported browser and ensure that users are accessing the content in a supported set up. If you can advise them to clear the cache and the steps as above it'll confirm that they're not having a browser memory issue that is causing the video to freeze.
Lim Guan

Hi, 

Any updates on this please? I have developed an Corporate Ethics course for a client, this course had went out to all employees. Users are reporting that the course stops/hang/freeze in the middle of the course. They are using IE11 as per company policy. 

I've tried accessing the courses using IE11 on my side and it's working well. Thought this was more of a browser/computer setting but seems that a number of developer are encountering this issue. 

Please let me know if there is any thing/setting that can be done/check within Storyline? Client users is using SuccessFactor LMS. 

Ashley Terwilliger-Pollard

Hi Lim, 

Are you able to have them check the browser set up in terms of the Flash player associated with their browser? That could still be limited to each specific browser and therefore individual. The steps shared above should assist with going through that.

The other thought is a lot of times Internet Explorer may display as a particular version but it's actually running in compatibility mode which will force it to work based on an older IE browser specification. 

Here's a quick Peek at how to see if IE 11 is running in compatibility mode recorded by my colleague Justin.  If you confirm this is happening, a next step might be to test your Storyline course in SCORM Cloud and see if IE is being forced into compatibility mode there as well. That'll at least give you some more information to share with with your Success Factors team or internal IT about not letting IE go to compatibility mode. 

Adam Hunt

I am having the same issue. We are getting reports of learners getting stuck at various points within the module.  It seems like sometimes the navigation buttons (custom, not on the player) buttons don't display, other times they get a blank slide (with only the background image). We have not been able to identify any trends with regards to browser (some are using IE, others Chrome), nor is it any one particular slide or scene (have had reports of users getting stuck in each of the 6 sections). However, other users have been able to go through the course with no issue at all. They are all accessing the content through our company's LMS, but that is as much control we have over how they access it - there could be any number of different browser (and browser versions) in use, so troubleshooting browsers is a non-starter. What would cause a published storyline 360 course to have intermittent errors?

Crystal Horn

Hi Adam. I'm sorry you're having a tough time troubleshooting this one.

  • Is this only happening on one course in particular? We're happy to test it out in several environments on our end!
  • Does reloading the page help the content continue to progress?
  • If you upload the same content to SCORM Cloud, is it possible to get any of those affected learners to launch it from that environment?
Adam Hunt

Answers:

  • Yes - this is specific to one course. What is very odd is that it is one of two courses I created simultaneously. Since they are related content-wise, the structure is essentially the same and we do not have any issues with the other course.
  • No, reloading the page does not help
  • Scorm cloud is not an option for our users. They need to work through our LMS system in order to complete the certification that the course provides...and by rule we only house our content on our LMS.
Madhu Goswami

Hello,

I have been facing the same issue where the learners are getting stuck on random pages and the course wont move. I also faced the same issue while taking the course on Chrome. I tried to delete the cookies and temp files and then the course would work but also the same solution did not work for some people and they were still stuck even after deleting cookies. Now since Dec 2020 Flash is no longer supported by Chrome and I published the course in HTML5 format. Has there been any solution to this problem? If there is any recommendation, that would be very helpful. Thank you!

Leslie McKerchie

Hello Madhu and welcome to E-Learning Heroes. 😊

Thanks for reaching out and sharing that you're running into a similar issue.

What version of Storyline are you currently using?

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

James John

We're seeing he same issue in an extremely huge Storyline course (>300 slides - don't ask...) that we're chipping away at and we've sent some data to Articulate Support. We've had a go at enhancing in the distribute yet we're actually seeing the course freeze on specific frameworks. I'll return again if/when we learn something...

Leslie McKerchie

Hello Abdul, and welcome to E-Learning Heroes. 😊

Thank you for reaching out and sharing what you are experiencing. 

I'd like you to share your project file with our support engineers to investigate what's happening with your permission. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Christiana Awojinrin

Hi there, sorry but I’m going to add to the crowd experiencing this issue.  Over the last few weeks, users here have been  reporting random unresponsive screens for our software simulation e-learning courses. These courses have been live without issues for over a year. 

Our users mostly use the latest version of Chrome for the web based e-learning but some have resorted to MS Edge following the above issue.  However, the problem occurs in either browser!  

It is annoyingly random - affecting remote users and those on site, Chrome and MS Edge users.  All users, however, are on Windows 10. 

I was able to fully complete a particular course with no issues two days ago but, today, using the same PC and browser, the course refused to progress beyond the initial slide.  I refreshed the Chrome browser and restarted the course and made progress until the course refused to budge beyond the slide that followed my initial problem slide!  

I recorded the frustrating impact of this issue in the attached video. The course registers my  correct and incorrect mouse actions but  refuses to progress to the next slide. 

I’ll be happy to share my storyline project files because this problem is driving me and busy clinical users to distraction!

A solution would be greatly appreciated! 

 

Christiana Awojinrin

Hi Leslie

Many thanks for the below. The Chrome update has been implemented and I am unable to reproduce the issue after repeatedly (10 times) working through a course that previously halted frequently!

However, do you have any idea when the equivalent update will be applied to the Chromium engine of Microsoft Edge?

Kind regards
Christiana

Leslie McKerchie

I'm not sure, Christiana.

What version of Edge are you currently using?

I'd like you to share your project file with our support engineers to investigate what's happening with your permission. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

Christiana Awojinrin

Hi Leslie,

Signature removed, thanks!   

We use Microsoft Edge Version 92.0.902.62 (Official build) (64-bit).

I have already shared my Storyline file.  It's Case Number: 02855976.

The issue is still present when the web course is accessed in an Edge browser.

 

Kind regards

Chrissy