What we’re doing to help you update your courses for browser auto-play settings (updated 12/06/2018)

Recently some common browsers, including Chrome and Safari, have started blocking auto-play of audio and video content on the sites you visit. That includes audio and video in e-learning courses that are hosted online.

That means that audio or video on the first slide of a course will not automatically play. It also means that videos and audio won’t work when learners suspend a course and restart on a slide that contains audio or video. Your content won’t be affected by this issue unless videos and audio are set to play automatically.

Unfortunately there’s nothing you can do to override the browser’s settings. That’s why we released updates for Storyline 360, Studio 360, Storyline 3, and Storyline 2 to automatically detect when this occurs and present the learner with a play button overlay. That user interaction is what the browser needs in order to play the audio or video. If your courses have a required user interaction on the first slide and no media, you may not need to republish to have the media autoplay.

We’re working on a content updater for Storyline 360, Studio 360, Storyline 3, Storyline 2 and Studio '13 that’ll let you mass update all your courses. In the meantime, you’ll need to republish your courses one at a time to fix this issue.

We know this is super frustrating, and we’re so sorry for the trouble. We’ll keep you posted on our progress.

UPDATE (12/06/2018): We've now created a tool that lets you mass update existing courses without republishing them. Currently, the updater works on Storyline 360, Storyline 3, Studio 360, Storyline 2, and Studio '13 courses. See this article for details!

165 Replies
Ashley Terwilliger

Hi all,

Just a quick update, we fixed the issue in Storyline 2 where if you accessed a course that has audio on the first slide, you wouldn't hear the audio on the first slide when you play the course locally using Google Chrome Version 66.0.3359.139 (Official Build) (64-bit) or later. 

You'll want to download the latest update, or use the Articulate updater for Storyline 2 to republish your content to include that fix. 

Andy Wood

I just wanted to share something with other users as a heads up. I ran the latest updater on a 3 TB hard drive where we keep our longer term file storage. While it took a while to complete, the process appeared to work fine. However, the updater did require extensive scratch space on my local hard drive. I believe it tied up 45 GB of scratch space while scanning and fixing content. Because my hard drive filled up, other applications I tried to use ran into issues.

Long story short...if you need to scan and patch a larger drive, some applications on your machine may not be available to you depending on how much free disk space you have available on your machine. 

Justin Grenier

UPDATE:  Since the original release of Chrome 66 effectively broke a lot of web content, (such as e-learning courses with audio introductions), Google responded to the cries for help and delayed their policy again in October.

But this reprieve was temporary.  Google has now stopped autoplaying audio again in December 2018 with the release of Chrome 71.  And with the software updates and content updaters mentioned above, you’re ready to go!

Will Findlay

I published the example above this morning (as well as a real course) using what I assume is the most current version of Studio 360 as it is dated October 2, 2018. I guess what I am proposing here is that the fix must not be working for Presenter 360 content when viewed in Chrome 71.

Browser version info:

Google Chrome 71.0.3578.80 (Official Build) (64-bit) (cohort: 71_Win_80)
Revision 2ac50e7249fbd55e6f517a28131605c9fb9fe897-refs/branch-heads/3578@{#860}
OS Windows
JavaScript V8 7.1.302.28

Ashley Terwilliger

Hi Graham,

Only with Studio 360 courses and Chrome 71 - the course will begin but the audio may not start until the learner interacts with the slide.

Chrome 71 did add a setting to allow you to override this, follow the below path to change it: 

Chrome > Settings > Content Settings > Sound > Allow > [ADD BUTTON] > Enter URL

We'll keep you posted with any other updates on this here! 

Meir Gabay

Hi,

We have more than 2000 SCORM packages in our LMS (CSOD)

Is there any way to instruct our customers to tweak something in Chrome?

I've tried this: Chrome > Settings > Content Settings > Sound > Allow > [ADD BUTTON] > Enter URL

But doesn't seem to do anything, we still get blank screens / impossible to click on resume/next or anything.

This happens only for SCORM 2004 packages, in SCORM 1.2 packages all is good

 

Meir Gabay

Hello Ashley,

This is what I saw when I had resumed a SCORM package. I'll upload a GIF later on today that will show you what happens when I start and resume SCORM lessons.

I'm using Chrome v71, and can confirm that this didn't happen on v70, also on other machines. I can also confirm that all the problematic lessons work on IE11

I've already reached out Google, we (NICE) need a solution that avoids republishing all our SCORM packages

Crystal Horn

Hi Meir.  Thanks for confirming you're using Chrome v71.  Are you using Storyline or Studio to build this course?  If you can let me know which version, and even include a project file, that would be helpful! 

I tested in Studio '13, and both the Flash and the HTML5 output showed all of the normal resume text in Chrome.  I published for SCORM 2004 and hosted in SCORM Cloud.  You can check this link and see what happens on your end.

Marie DesJardin

Hello, Articulate team! I am republishing a course in Storyline 3, and the autoplay fix for Chrome is not working. The first slide is silent, and no play button appears. (IE plays fine.)

I am using the latest version of Storyline 3 and the most current Chrome browser. I went back and checked, and a course I had published recently (in December) now does not show the autoplay button. Did Chrome change something again? 

Many thanks. 

Marie DesJardin

Update: I played with this some more, and discovered the Play button is linked to the SL3 publishing format. If I publish with HTML5 with Flash fallback, I get _no_ play  button.

If I publish HTML5 only, I do see the Play button. Is this difference related to Chrome or to SL3? It would be very nice if I didn't have to republish numerous courses that I just published. 

Thank you!

Marie DesJardin

Update to the Update: Alas, the HTML5 fix works only when I view the published content on my computer. After I publish to the LMS (which I did with two separate course files), I still do not see the autoplay button.

I then posted both courses to the SCORM cloud. Double alas-- even the HTML5-only version does not play correctly. Here's a link to one of them: https://cloud.scorm.com/sc/InvitationConfirmEmail?publicInvitationId=fdb5d32f-ed3c-4373-9433-f504f0f6bdfc

Thanks for your help in solving this!