Rise Storyline block showing a play button

Hi,

I am developing a Rise module where I am including a couple of Storyline blocks. I am using 2 SL blocks in the same Rise section. When you reach the first one, it just shows a dark grey background with a play button in the centre. When you click the play button the SL block is active. However, the next in line SL block the SL block displays the content of the slide and I can access it without pressing a play button. Why is there a play button in the first SL block? I don't want the play button to show. There are no video or audio files in the SL slides. There are no timeline triggers in the base layer either. I have used SL blocks in other sections of this Rise module and they don't show the Play button. I have attached a screen shot. Thanks Cheers Gerry

26 Replies
Alyssa Gomez

Hi Steve!

You'll see the play button covering the Storyline Block if there is audio or video on the first slide. Learners just need to click the play button to start the slides, and the media will play as expected. This is expected behavior since Chrome requires a "click" to allow autoplay of media.

You can prevent this by adding an intro slide to the beginning of the Storyline block that contains no media files.

Nicola Fern

Hi

is this still expected behaviour if there is media on the slide but not on the base layer?

I had a single slide interaction that was working fine. It plays audio by jumping to layers when you click the buttons. I made some small changes to improve usability after it has been up for a long time (I removed the seek bar, which was confusing people, and now have play, pause and restart buttons on each layer). Now, when I have re-uploaded the SL object to review, it loads with the black box. Any idea if this *should* be happening, or if it’s a bug

Thanks

Nic

Rupert Abel

Something I have noticed here though, I assume people are talking about running the output on a PC?

I find if I run the output on ipad or android phone, the play button is always above the content to play it, without the slide having any media on it.

In fact to demonstrate this , I created a storyline file with just 1 screen and a text box on it. Nothing else.

This is far from ideal. You want the content there ready to play on an ipad/android phone, you do not want the user having to press a play button.

Does anyone know a solution for this or is this just the way it goes? Thanks.

DJ Irvin

In my Rise lesson there is one Storyline block.  On a PC no play button appears.  On a tablet the play button appears and when clicked the Storyline block plays.  That's all good!  BUT when I preview on a phone the play button apprears (which is okay) BUT it does now respond when I click the play button.  Nothing happens.  

Any ideas on why it would play on a tablet but not on a phone?

 

Roxie Capewell

Hello Alyssa and DJ Irvin this is the same issue i'm having and also the sample course on my Rise account "Employee Health and Wellness (Sample Course)" It has a Storyline block on which when i preview in tablet or phone mode the Play button doesn't seem to appear! how did you guys get this to work! When everyone is asking how to remove the play button itself!

BTW im only checking on the preview mode inside Rise that the play button appears and that the Play button does not do anything when i click into it inside Rise Phone preview mode, the same issue that DJ Irvin is having

Any more news on this 

Alex Hoffman

Is there any way around this play button? I know they appear when there's audio on the first slide, but it doesn't play unless the user wants it to, so it's not like an annoying auto-play issue. This confused several users in testing since they expected a video to play, when in fact the content is mostly static, unless interacted with. It would be much less confusing without this play icon.

Alyssa Gomez

Hi Alex!

On desktop computers, you'll see a play button if the Storyline block contains any kind of media on the first slide. The play button may eventually disappear when your browser learns you've allowed media to play on the hosting site. 

To work around this play button, you can create a new "first slide" in the Storyline content that mimics the current first slide but doesn't have any audio on it. 

Simply duplicate the first slide to create a copy of it. Then, delete the audio. Finally, add your own "Start" button that jumps to the next slide. 

Chino Navarro

Hi Ricardo! The play button in the Storyline block on a mobile device is expected behavior. It isn't possible to disable this. You mentioned that after closing the Storyline interaction window, it mixes with the content below? Can you tell me more about how it mixes with the other content? Can you send a screenshot of how it looks like?

Learning and Development iFive

I'm also experiencing the same issue, even on desktop, the play button is still visible. I checked if there are any media (video/audio) on my slides that might be causing the issue; I followed other suggestion like duplicating slides and making sure there are no audio/video on the base slide.