87 Replies
Matthew Thompson

I'm having the same problem. It was fine until I did the update yesterday now Photos, Illustrations and Icons will not work. A co-worker who did not complete the upgrade yet is not experiencing the same problem. I will see if I can revert to the old one (but my IT department may not permit me to do that). I hope Articulate doesn't ignore this issue and gets it resolved quickly. This is a huge inconvenience!

Ashley Terwilliger-Pollard

Hi all,

Thanks for reaching out here, and I'm sorry for the trouble you've run into.

Our team has identified the issue in Update 33 and it's related to particular proxy settings for some of our users. Since our team isn't behind any similar proxy settings, it didn't pop up in any of our testing, but was identified through working with customers to view their diagnostic logs.

We've got a fix in place and we're running through our final sanity checks, but should have some news for you next week. We'll share here as soon as we're ready! 

The original issue in this discussion was around users who were connecting through a VPN, which can still cause issues with how Articulate 360 accesses the Content Library assets.

Ashley Terwilliger-Pollard

Hi all,

Thanks for your patience while our team fixed the issue where Content Library 360 search results wouldn't always load for authors behind a proxy server. Today's Update 33 hotfix resolves the problem, so be sure to download and install the update today from your Articulate 360 Desktop app! 

Richard Ekparian

And we appear to be having the same issue. I'm trying to download assets from Content Library 360 in SL360 and while I can see the images with no issues, I receive an error message that something went wrong when I try to download. 

I would also rather not have to roll back to a previous version.



Trevor MacDonald

I am having the same issue. When using Rise (online) I get several rows of thumbnails and then a few rows of warning triangles. If I click on a warning triangle the 'mystery' image imports. I can replicate the issue in the locally installed Storyline 360 except clicking on a warning triangle leads to a 'download failed' error. I ran diagnostics through the Articulate 360 Web App and found a clue under the LOGS > LATEST MESSAGES:  

[10:19:40] Download failed: https://pixabay.com/get/54e8dd474a50af14ea89877ecf29327c1322dfe05455734f752b7bd5.jpg; The remote server returned an error: (503) Server Unavailable.

There are dozens of entries for what appears to be several images over the course of just a few seconds. Our IT support desk has asked that connect with customer support. I stumbled upon this thread and figured I would update with my details first.

Deepa Jaisinghani

I am not sure if people are still experiencing this issue.. i seem to have hit a roadblock on this. I cannot download any asset from the Content library... icons or photos or anything really...  i get the same exclamation mark all through...

Can someone guide me for this please.... 


I guess i started having this issue after the update as well... i have reverted back to previous version but still not able to access the library... :(

Rachel James

Good morning.

This has been an off-and-on issue since December. Currently, no I do not have access to the content library.

Since we're a government agency, a lot of our permissions come from Harrisburg. We escalated this to them to remove a firewall, as we suspect that is the cause of the problem.


Rachel D. James | Clerk Typist III, Staff Development/QI
PA Department of Human Services | Wernersville State Hospital
160 Main Street, Hill Hall | Wernersville, PA 19565
Phone: 610-670-4100 x5269