ERROR: Being used by another process

My files every now and they pop up with the error:

"the file XXXX' is being used by another process or you do not have the proper security permissions to access this resource"

Our IT Dept spent and hour last time trying to figure out how to open it and still that wasnt an ideal solution. Anyone know how to hard reset Storyline?

46 Replies
David Bashen

That is correct. After the Articulate auto update I cannot open story files without encountering this error. However.  However if you have your story file listed in Most Recent list on the left you can open it from there without issue. Seems to be problem opening when clicking on the story file.  A second option is to rename the file before clicking on it , however that is very irritating to keep doing over and over.

Lauren Connelly

Hi all!

I ran into this situation with a customer and luckily we were able to solve the issue. 

This is what worked:

  • Find the project in File Explorer.
  • Copy the project. Right-click and click "copy" in the dropdown.
  • Go to your "Documents" folder and create a new folder.
  • Paste the project into the new folder.
  • Open Storyline, and open the project.

Keep me posted!

Lauren Connelly

Hi James!

I understand the hassle! There are a few instances that initiate this error message.

Images or other elements open in other programs. For example, viewing an image in Paint, even in the background, will cause this issue because the software recognizes an instance of the image is in use. Also, I would check that all of the content items are on your hard drive, rather than accessing them from a USB drive, network, etc.

James Washok

Oh, it's just a hassle now; I've been able to work around it without an issue. The thing is, it doesn't matter if I'm working from a network file or a local file. I still get the error message intermittently. Again, all I end up doing is closing SL360 and copying the file to another location, either on our server or on my desktop, and then open it...voila, no error message.

As for the file using objects that are opened in another application, tried that, doesn't matter. When it first happened, I closed everything (Illustrator, Photoshop, PPT) and then tried once more...same error message with the same file. It was then that I tried the "copy/move" option and found that it worked. So, it's not associated with another application using the assets in the SL360 file, nor where the SL360 file is stored or accessed from.

Trevor Slydel

With all due respect Lauren, I wouldn't say that you solved the issue with your customer, you used a workaround. This issue continues to occur with us and creating loads of copies of our working files does not seem like a practical solution.

As for having elements open in other programs - I see no reason why this should have an effect. I  do all my image work in Photoshop, save a png and import it into Storyline. How is that linked in any way?

Lauren Connelly

Hi James and Trevor!

Trevor, I appreciate the feedback! In my customer's scenario, that was the solution since the project was being used by another employee on their server. The customer needed a copy of the project on their own local drive to continue authoring the course.

It sounds like you've come across a different scenario.

It would be best for our Support Engineers to dig deeper into the issue. Please use this link to start a case. 

Stephanie Verhoeven

Hi, 

Since a couple of weeks the problem above also occurs on my computer. The problem seems to occurs after publishing the module in Review 360. After making a copy of the document it works again but I made so many copies of one document i'm getting a bit frustrated.. 

Can you please advise?

April Hilbert

I have also now been encountering this issue for the last week or so. I continually have to make a copy and rename the file. I originally had it on a network drive but have now moved it to my local drive and it is still happening. There are no other programs open when I am attempting to open the file. From the responses on this thread, it seems this is a common occurrence for people recently...

Katie Riggio

Greetings, April!

You took the right steps by copying the file over to a local drive, and I'm so sorry this error is still lingering!

Would you be willing to work with our Support Engineers, so we can pull a few system logs to help us determine the next troubleshooting steps? They'll do what they can to ensure this issue doesn't appear again!

Robin Kouvaras

I am encountering this error every time I open the project in Storyline.   I'm wondering if the engineers have found any correlation with previewing the story.  I am not 100% certain but the problem seems to occur after you preview the project.  Has there been any progress in resolving?  Thank you!

Lauren Connelly

Hi Barb!

If you're making copies of your project, then you'll want to make sure they have different names. One way that I avoid this error message is to add the date to the file name whenever I make a change to it. For instance, TestCourse 1.13.2020.

Do you have multiple versions of the same file on your computer, or are you backing up the courses to another disk? If so, you'll want to make sure you're making edits to the file on your local drive. 

Jake Munn

Lauren,

Is storyline's stance on this issue is to simply make a copy of a project each time we want to save it? That is complete absurdity. We are constranctly working on projects. This is a must have basic functionality of any program. To be able to save the file.

You need to fix this issue now. We have been dealing with this for over 8 months now.

Fix it.

Murl Sprout

Ever since I updated SL360 the other day, when I open any file, I get an alert (see attached screenshot) saying the file "is being used by another process or you do not have the proper security permission to access this resource. Make a copy of your project file, then try to open the new file." Making and opening a copy works but that is, obviously, a pain in the ashphalt having to do it each time. I there a repair coming so we don't have to do that? 

Lauren Connelly

Hi Murl!

I understand how that would be a pain when there are multiple project files! Are you saving the files to an external server? If so, you'll want to make sure that you're copying the files to your local drive and opening them from there. 

This error message will appear if there are multiple copies with the same name.

One way that I stay ahead of this is by naming my files each time I open/edit. For example, if I opened a course today and made edits then I would save it as "SampleCourse 1.29.2020". It also helps me easily find the most updated version.