Project won't save - Storyline 2

Getting a different error nearly every time.

Cannot access part because parent package was closed.

Cannot access a closed stream

Store must be open for this operation.

What gives? I can't re-save it as a new file. I'm screwed. About to lose half a day of work here. Any help? We've had this for less than a week, and never had (major) issues with Storyline 1, like this. Saving on C drive. Windows 7. 

Please get back to me asap.

187 Replies
Peter Bennett

I've got a file that just hangs every time I try and save.  It was created in SL2, it has numerous videos, and is quite large.  But it saved numerous times before.  Now, every time I try to make an edit and save, the program is unresponsive and I lose all my edits.  I've probably wasted 6 hours trying to make 15 minutes work of edits.  I've got deadlines and no one wants to hear that the software isn't responsive.

The instability of Storyline is extremely disappointing.  Having to work from local machines and having saving problems are kind of a big deal with a software program.  I feel like the software shouldn't even be available if these types of problems are so consistent.

Ashley Terwilliger

Hi Peter,

Thanks for reaching out here and sharing your experience, which I'm sorry to hear has been so time consuming and trying. I'd like to have you work with our Support engineers so that we could take a look at this problematic file and anything else specific on your system. I assume you've already run through the steps in this thread in regards to working locally, repairing Storyline, importing it into a new file, confirming you're on the latest update (Update 7), etc.? 

I've gone ahead and submitted a case on your behalf so you'll be hearing from someone on our team shortly. 

Greg Hagar

I am also getting this error. Update 7 installed. Frequent errors and crashes on save with SL2 occurring on a near daily basis now. Variety of errors - no disk space, locked processes, can't generate xml. Following all the usual fixes (rebooting / updating / reinstalling /working from local files).

I like using SL2, but these long running and persistent issues are getting very, very old.

Karisa Munoz

Two members of my staff have received this error more than once as well. It seems to keep happening on the same computers and the same projects once it starts.  It also happens to projects that we have saved awhile ago.  One of the notes above says it happens more often with files created in Storyline 1 that have been updated but it has also happened with new files that we have created in Storyline 2.  We also get errors telling us there is not enough space when working on our computer locally as recommended.

We are considering switching to another product because it seems like both these issues have been reported by numerous people and no updates have been made and no one seems to be getting anywhere with tech support.  We have sent files in and I have just opened another case and will send the file if we are indeed ever able to send it.  We need to have a program we can count on and this is such a loss to us since we actually like working with it.  Now our team will need to learn a whole new program costing us even more time in addition to the work we have lost.

Jean-Guy  Boulay

We at work here have figured this out to be an issue with the amount of video in a course and the auto-recovery (some kind of limit). We just turned off auto-recovery. However, we haven't seen the issue even with auto-recovery turn on since we've installed update 6 and 7. Good luck, I know how frustrating it can be.

Leslie McKerchie

Hi Karisa! I see where you reached out to our support team and I see a couple of others as well. I will have someone reach out to you in your support case as it doesn't seem like we are getting any subsequent feedback/replies, so let's be sure that our messages are reaching you so we can continue to assist. (For my reference: 00765849, 00735680, 00734160, 00456864)

Jean-Guy  Boulay

I personally haven’t had this issue in two years. You shouldn’t be encountering this issue anymore if you have updated lately. This was resolved I believe in update 5 or 6. 

But Storyline does a backup save (if you haven’t turned it off). Try browsing to \Users\<username>\AppData\Roaming\Articulate\Storyline
And inside you will see a bunch of tmp files. These are basically your .story files in backup. If you sort the file dates you should be able to find the project your currently working on. Copy that to another folder and rename it to a .story.

I think this was caused by having a massive project with videos. 

Good luck.

Tim Danes

I ran into this issue over the last couple of days, despite having the latest release.

I think it was caused by low disk space, combined with long save times (due to excessive video content).  My suspicion is that the autosave feature was half-way through a save when I chose to save.  Not sure, but thought I'd put up my information in case it helps someone.

I'm not sure what the solution is (as I can't reduce video content), but I cleared disk space, waited a bit, and re-saved, and it seems ok for the moment *fingers-crossed*

Continuing to love Articulate... thanks!

joe Skillington

I really don't like the fact that customers of Storyline are used as Beta testers for the software. The software should have been cleared before being sold onto the public. I understand there are always going to be issues but this software has to be up there with the worst on the market. People have paid for a service and then asked to help in making that service workable. I don't want a reply, or a "sorry to hear this" I'm just venting. Thanks

Noureen Shaikh

I am experiencing this issue with any file that I start from  scratch or not from a template.  If I use a previous SL2 file rather than starting from scratch, it seems to be okay.   However, it does recover it and let's me save it sometimes making multiple copies.  I have only experienced this on one laptop.  I have not tried to switch to another laptop yet.  

Pierre Jouan

Hi there!

A colleague just had this problem a few minutes ago on a SL project with quite a few videos.

She's running update 11, btw.

Denise, is your trick about renaming the file SL is trying to save to (like say renaming project.story to old_project.story)? We could rename the file (althought it should have been locked "in use") but SL did not recreate the original file...

We only could get an earlier version from temp folder...