Downloading Xliff files in Rise - different output

Nov 01, 2018

Hello everyone, I am facing some issues exporting the XLIFF files from our courses in Articulate Rise. 

I previously downloaded the same courses in the XLIFF format, however now I get xlf files with the internalised html and the file original code missing. The segmentation in the new downloaded file is also very different and poor.

As we already prepared these courses for translation and they are currently with the linguists, it would be quite problematic if we need to reprepare everything from scratch.

Is there a way to download the same format as before? What is this issue due to?



76 Replies
Eckart Fischer

When you read my comments above, you will see that we struggled with the same problems as you did. For a couple weeks we used the workaround via that Craig Sumner mentions above (thanks a lot for sharing that with us, Craig!). 

Today the big surprise: I imported a translated xlif-file and -- no error message, just an "OK"!! I didn't use any workaround. I just imported the file how I got it from our translation Office (the file came from the same translation office as in the past).

Maybe Articulate has fixed the problem? Has anybody of you tested an import during the past 24 hours? On my side it worked perfect today.


craig Sumner

If your file opens in and you can read the translations then the file is working and I would say there is an issue with Rise, if it does not open in then the file has possibly been outputted incorrectly.

You could try renaming the file ext also.

To do this I would make a copy of the file you have, rename the copy and where it says .xliff change it too .xlf and try importing into Rise again, I am not saying it will work but try it, this a solution I have read others use and which worked for me once or twice.

Justin Grenier

Hello, everyone.

Thanks for weighing in to let us know how important it is for us to get XLIFF translation right in Rise. We hear you, and we understand this is impacting you. Our team will be reaching out to each of you directly to schedule some focused time to get your feedback on the best way to fix this.

You'll hear directly from our team today.

Hanneke Portier

Hi everyone:

I encountered the same issues and found the following workaround:

  1. Duplicate the course.
  2. Export the 'xliff' file (which is really a .xlf file)
  3. Add .xliff to the exported .xlf file
  4. Upload this .xliff file to and download the file (in Internet Explorer, In Chrome the 'Download' button does not work!)
  5. In Chrome, import this converted file into the original course (NOT the duplication)
  6. Follow the same process for any other translation; the original course is now translated into another language, but it still needs to be THAT original file/course.
LS Tech

Thanks, @Haneke!

But, as far as I can see, there would be no way to translate everything automatically.

That is one of our main concerns, since segmentation changed when they decided to migrate from .xliff into .xlf, and we had to face many fuzzies for files that were already translated.

Regarding Tranzapp, thanks for the link. I was not aware of that tool. Is there any way to add TMs/automatically propagate the translations when there are repetitions?






Allison LaMotte

Hi everyone,

Some of you have told us that the tags we add to XLIFF exports (to preserve formatting) make those files hard to work with. 

If you’re one of those people, I’ve got some great news! You now have the option to discard that formatting in order to make XLIFF files easier to work with. Here’s more information on how that works. 

Keep in mind that if you decide not to include these HTML tags, any custom text formatting (size, color, boldness, etc.) that you’ve applied will be lost when you import your translation.

We've also reduced extra spaces in the export files so that they work better with third-party translators.

We’re hoping that these changes will relieve the pain that some of you have been experiencing with translation in Rise.

Thanks for your patience as we worked on this solution! 

Let me know if you have any questions.