Rise Closed Captions Not Working

Apr 02, 2021

Hello! I uploaded a video in Rise 360 that had closed captions created in Panopto, but there was no CC button on the video. I then uploaded a VTT file for it, and the CC button appeared but the captions did not when selected or deselected. I'm not sure which status is on/off. I added WEBVTT (per another discussion thread) to the beginning of the VTT file, but nothing changed.  I then realized that I needed to have .en.vtt in the name, so I added that and reuploaded.  Still no change. I've attached my VTT file if that helps.

Thanks for any assistance!

36 Replies
Alyssa Gomez

Hi Eileen!

I was able to get your VTT file to work in Rise 360 by making a few adjustments:

  1. Delete the numeral above each time code (shown below in red)
  2. Replace the commas in each time code with a period (shown below in blue)

After making those changes, the VTT file should look like this:

The file I attached includes updates for the first 4 captions. Try uploading this to your Rise video and let me know if you can see the first 4 captions correctly. You'll want to continue those changes for the remaining captions in that file. 

Regina Kirby

Hello - I am having a similar issue as well with several videos included in a Rise course. The closed captioning icon (cc) does not always display when the videos are viewed within the Rise course that is published to our LMS.  I created the videos in a third party app which does not include closed captioning. Therefore, I added the videos to a Storyline 360 slide, where I created the closed captioning (.vtt file). These Storyline files where then added into the Rise course. The cc icon works as expected when reviewing in Storyline and Rise. However, when I publish the Rise course into our LMS (SCORM 2004) the closed captioning icon randomly appears and disappears when viewing the videos. I did review the WEBVTT file (per Alyssa's instructions above) and see that the settings are correct per her tip (the number does not appear for each caption and there is a period, not a comma, in the time code).  Also, this issue did not exist in previous versions of the Rise course.

Hazel Bartolome

Hi Regina! So sorry to hear you're having trouble with the closes captions when your Rise course is published to your LMS.  Would it be okay for you to share your Rise course and Storyline file with us so we can take a look at what's happening?  You can upload your files privately here and one of our technical support engineers will be glad to assist you.

Anairis Perez

Hello everyone! Much like many of you, my company's IT team does not want us to use converters. This suggestion to use the Articulate captioning tool to export a VTT file was a clever solve, but unfortunately the VTT file that it generates still doesn't materialize in Rise 360 for me. Any troubleshooting tips for this?

I read here that a solve for this was to edit the VTT file directly and remove numbers and stamps on each line but my file has hundreds of lines and I'm looking for a process that will streamline this for our team. 

Any insight from you all would be great!

Nick Shelton

Same issue as @Anairis here. Can't use an online converter, the VTT from Storyline isn't working when we upload to Rise. We've published a Storyline block as a stop-gap and have opened a case.

I know VTT's are the preferred standard these days, but what about accepting other formats (SRT, etc) and/or ensuring captions exported from Storyline will work in Rise. I've done a few test exports from Storyline, as it's our captioning tool to create VTT's, but they're not working.

I'm running the 9.22.2022 update.

Alex Salima

Same issue as many above.  No captions and no CC option in the player during playback.  This worked fine in the past flawlessly.  We're just experiencing this odd behavior now.  Would like to find an immediate solution for this.  We have many courses where captions are used for other languages.  Appreciate any help!  Thanks.

Rise 0

+1 for Andrea and Alex problem, i have showcased using captions in Rise as a feature that adds value and now it has stopped working. The users in the team dont send in cases, they contact me. i can do nothing about this, i am guessing until enough votes for a fix is in?
Hoping then for a quick fix and public statement / update that it has been fixed.

Credibility is badly damaged when an online system starts to "sometimes work and sometimes not". Sold as a "professional production tool" the reliability is important.

Anairis Perez

Hey all!

I've still been experiencing the same issues, but I found a workaround: Since I do a lot of my video edits on Premiere I export the SRT file, then I open it with a notepad, add the text "WEBVTT" at the top leaving a line between this text and the first number. Then I replace all the commas with periods by using the find and replace feature in notes. 

Click "Save As" and change the .srt to .vtt on the name of the document.

Save as file type: "All Files" and make sure you're encoding it as UTF-8. 

This document loads into Rise perfectly.

It can be time intensive if you have a lot of videos you're working with, but for the sake of accessibility its worthwhile in the meantime.

Roger Hobbs

We had already been using WebVTT format, but we started experiencing the issue as of this week. Even on projects where captions were confirmed working in Rise previously, the captions no longer appear on playback in Rise. @Anairis, can you go into Rise and look at any project in Rise and see if the captions are still showing up for you?