IMPORTANT! - a fix if you have a PLAY button appearing at start of courses

May 04, 2018

OK, Articulate rolled out an update to Storyline and it seems that now when publishing a course, instead of auto-playing (as before) it now puts a nasty big PLAY button on the first screen.

Hopefully Articulate will roll out a fix (very!) soon.

In the meantime, I have discovered that AUDIO on the opening slide will cause this. Removing the audio, removed the PLAY button and things went back to normal.

Therefore to get round the issue, try what I did - create a tiny opening slide of a flat colour (same as your project background) and set it to be your opening slide.

Worked well for me, and thankfully I can now stop hearing screaming from my clients.

113 Replies
Ashley Terwilliger-Pollard

Hi Breda,

The button design/color is currently set to the greyed out mode so that it's easily distinguishable for learners to click on to start the course. If having the ability to change the coloring and design is something that would improve your experience (and that of your learners) can you share a bit more detail by submitting a feature request here

Michelle Frederick

I just want to be sure I understand. The only way to have my audio play on my second slide when using the "add a slide that runs for .25 seconds" fix is by having the user do something on that specific page.

I'm basing this on Ashley's comment in the thread "you'll need to have some user initiation on the first slide to allow the audio to play. This is browser and domain-specific as if the user has previously allowed audio to play on that site (i.e. pressed play, unmuted it, etc.) Chrome is keeping track of that and using it to determine how it should behave in the future."

We have several courses that were published that had this issue. We used the "add a slide" fix and it worked. Now we are updating and while we don't see the play button, the audio is no longer automatically starting. We are also experiencing the Play button showing on any engage interactions we have imported into Storyline. 

Are these two things related? Has anyone figured a fix for this? Any help is greatly appreciated!!

Katie Riggio

Hello, Michelle. Great questions, and I'm happy to explore both scenarios with you!

  1. Autoplay behavior for media that isn't on the first slide: Audio and video content on other slides should play as expected. However, if your slides are set to advance automatically without any interaction, that media might not work since learners haven't allowed their browsers to play it. Click here for how to make sure that audio plays correctly throughout your course!
  2. The play button appearing on Engage interactions that get imported into Storyline: We've logged this as a separate bug, and I'm sorry you experienced it. I'll add your voice to its report so we can keep you in the loop on any new development! In the meantime, clicking the play button will launch the Engage interaction. 

Let me know if that helps, or if you see something different!

Michelle Frederick

The fix most commonly mentioned worked originally. However with the release of Chrome 71 ( https://developers.google.com/web/updates/2018/11/web-audio-autoplay) in December 2018 the audio piece would not auto-play.

The .25 second slide did not have any interaction and was intended to move automatically to the next slide (both being identical) so the big ugly play button didn’t show. The first “real” slide had audio on it and it used to play automatically but with the update (Chrome 71) it no longer does. It needs some form of user interaction on the page in order to “understand” that the person wants to interact with the media.

What I’ve heard at this point from other developers is that you either need to 1. Add some form of interaction on that first slide (like a play button) or 2. Ensure the slide directly after the .25 slide doesn’t have audio. The act of either pressing a button or choosing Next to start the course “tells” the browser that the user does want to interact with the audio that will be played on the next slide  

The Chrome update does make sense. I mean, if I accidentally went to a website and video or audio just started to play without any action on my part, I wouldn’t be happy. I want to control when that audio or video starts. 

 

Anyway, I hope this helps some of you. 

Will Findlay

Just make sure not to use the On Restart: Always Resume option with courses. This bypasses showing the screen that gives the user the option to resume or restart the course when they come back into the course. Instead it takes them directly to the last slide they were on. If the last slide they were on included audio or video, it won't play. 

Andrew Hanley
PS Huynh

It looks like the problem hasn't been fixed after 2 years. I had a video in the first slide of the project and after I published and played, the grey background and the big play button showed up. I pulled my hair out trying to figure out what had happened this project until I saw this thread.

In fairness to Articulate here, its not a problem of their own creation. The reason you are seeing this big play button is because of the browsers security settings.

Removing any audio or video from the first slide of a course, and putting some sort of interaction requirement there (like a "START" button) should eliminate the issue.

What I would have liked to see from Articulate is some acknowledgement of this, and options for working with this new browser limitation. For example, being able to design the play button which appears, or choose from different options. Even a warning when publishing could be a big help for some.

Chris Roetzer

So I tripped over this annoying play button issue today as I have an audio music track play on my title slide (as well as slides 2 and 3); I see the grey screen/play media button when looking at the course in Review 360 for the title slide (slide 1).

I haven't poured thru the preceding 97 comments but I need a clickable button on the first slide that contains audio or video to start/begin and that should resolve? or is the answer both a 1/4 sec slide with a start button (no audio) followed by slide 2 that does have audio, but slide 2 also needs a start/play media triggered button too?

So annoying and confusing, thanks Chrome.

Michelle Frederick

I’ve used the two slide option. Have it auto advance to slide two. Then from there you can pretty much do whatever you want. Just be sure the slides are identical with the first one having no media or it will look goofy.
It’s just getting past that pesky first slide. Good luck! Post again if you need any more info. Happy to help. 

Chris Roetzer

Hey Michelle, TY for quick reply - While the media play button doesn't appear anymore, the audio on slide 2 won't play when moving to slide 2 when Slide 1 timeline ends (I set 2 sec.), nor will it play even when adding a trigger to Slide 2 to play the audio file when the timeline begins.

What does work though is a triggered "Begin" button on the title slide to jump to slide 2 when clicked; Slide 2's audio auto-played (don't need a play media trigger). So pesky! But getting past the title slide with no media works provided you use a user-triggered jump...

I adjusted shapes/animation so that when Slide 2 appears, it's identical to how the Title slide 1 appeared when its timeline ended (so as you mentioned, nothing changes in the user's view of that transition).