Storyline 2 freezing when I try to Publish

Hi,

I have now noticed that when I go to publish, the Publish window greys out and it just hangs. I can press the button to cancel and it asks me if I am sure, pressing Yes, just continues on hanging.

If I kill Storyline in the Task Manager, relaunch the program, and immediately publish it will work. I then make a few changes and it then hangs again.

All files are on a local drive and it was working fine until today.

any suggestions would be grateful.

190 Replies
Leslie McKerchie

Hi Darren and Kelli!

Are you having issues with just one project or with all projects in Storyline 2?

If you are having issues in general, sounds like you may need to conduct a repair of your software. Please note, that you should also be utilizing the latest update, and this update will repair your software as well.

Trevor White-Miller

Hi Leslie, I have the same issue as stated above with all new course builds and have to close with task manager. This is only occurring the very first time I try to publish a new course. After that it is publishing OK. I upgraded as soon as release 1 was made available but it hasn't made any difference.

Trevor

Ashley Terwilliger

Hi Trevor,

Just to confirm, you're using SL2 Update 1, and on brand new files you've created in SL2 while working on your local drive, and publishing to a local drive - the publish process freezes. Once you close down Storyline and reopen the same file, you're able to publish as normal? 

Could you share a copy of one of these files with us? I'd like to see if I can replicate the behavior with your file. After that, I know you mentioned updating - but have you looked into the full repair here? 

Trevor White-Miller

Hi Ashley. Yes it is SL2 Update1. I get the same error with a brand new file and also any brand new files where slides are imported from other SL2 story files. All your other assumes are correct. Files were made and published on the local drive. It does appear to be a one time error per each file, once it has occurred it doesn't happen again on that file.

I have done a full repair when trying to fix my variable problem from a different post.

I have a file which had the issue which I can send to you but as it has already be successfully published (on the second try) and then saved not sure you will see the error on that copy. I'll try making a few test files and if I know every single one files throws up the error on first publishing (which I'm sure they will), I'll send you a fresh unpublished test file which gives you the best chance of seeing the same error.

I'll make them tomorrow morning (UK time).

Trevor

 

Ashley Terwilliger

Thanks Trevor - and please keep us posted. It sounds system specific, but I'd like to see if a file from your system causes the same error. Since you've already done the repair - you may also want to look at pulling the error logs as described here to so that our support team can take a look. 

Ashley Terwilliger

Hi Becky,

Your situation sounds the opposite of Trevor's - as his freezes when trying to publish the first time, but after closing it down he can publish. 

Are you seeing this on all your files that you try to publish - even just a brand new file with a few slides that you started locally? If so, you'll want to go through the repair steps here. 

Hassan Mujtaba

Hi Ashley,

I am using SL2 Update 1. I face this issue (SL2 freezing while publishing) at least twice a day. I have noticed this in files which were created from scratch in SL2 or converted from SL1. Please note that this happens randomly and I can't replicate it. 

I wish I could provide you more information.

Thanks, 

Hassan

Trevor White-Miller

Ashley, Seems there is still a big problem with publishing in SL2 even after Update 1.

I have spotted a pattern in my particular case i.e. only happening the first time I publish a file. It appears that if I change any of the publishing settings and then press publish the system freezes. When I start the the course and publish again without changing any publishing settings then publishing works. When it freezes I'm very careful how I kill Storyline 2. In task manager I choose to end the process however instead of pressing 'end' in the task manager pop message Storyline also pops up a message offering me the option to 'Save' before closing Storyline 2. I always save and close with the Storyline pop-up not the task manager pop-up. So I just use task manager to trigger the Storyline pop-up.

This late Storyline Save appears to retain the latest Publish settings before the freeze so I don't need to change the publish settings the next time.

Interestingly today I had to try publishing a course with three different settings to see which one worked on a particular LMS. As I changed publish settings I was running into the freezing issues again.

Hope this info helps track down the issue.

Trevor  

Will Findlay

Yep - I also get the same option to Save right after choosing to end the process.

It almost makes me wonder if, when you click Publish and it freezes, the save dialog box is erroneously opening BEHIND the Publish dialog box and waiting for a response, but since it is behind a modal dialog box (meaning a type of window that locks out interaction with anything else in the application) you can't get to it. Then when you try to force the program to close, it comes to the front for some reason. But there are definitely some holes to that theory.

Ashley Terwilliger

Hi all,

Thanks for sharing the additional information here. I still have yet to see this on one of my SL2 files, but I'd like to see if you could share one that you know previously caused the crash -I'll import it into a new Storyline project to treat it as a brand new publish and how it behaves. 

Also, to confirm, you're also all publishing to a local drive as described here, with a file path and name that is under the 256 character limit and doesn't include any special characters, accents, etc.  Do you have any other files, applications, programs open while publishing Storyline? 

Becky Barch

I just did a test. I opened a SL1 file, upgraded it to SL2 and tried to publish.  SL2 froze and I did not get a Storyline popup to save. Had to use Task Manager to get out of SL2. Reopened SL2 opened a new project created in SL2. Published fine. Closed that project opened the upgraded project and it published.

Also running on a 64bit with Windows 7.

Ashley Terwilliger

Hi Becky,

Do you have a problematic file we could test? You can attach it here to the forums or feel free to send it along to our support engineers here.  

The repair steps are fairly detailed and involved, and if you're still having issues after installing update 1, it wouldn't hurt to go through the steps detailed here.  You'll also wnat to check that you're following along with the other general Storyline guidelines here.