Storyline 2 freezing when I try to Publish

Hi,

I have now noticed that when I go to publish, the Publish window greys out and it just hangs. I can press the button to cancel and it asks me if I am sure, pressing Yes, just continues on hanging.

If I kill Storyline in the Task Manager, relaunch the program, and immediately publish it will work. I then make a few changes and it then hangs again.

All files are on a local drive and it was working fine until today.

any suggestions would be grateful.

190 Replies
Ashley Terwilliger-Pollard

Hi Kim,

There was a fix in Update 5 of Storyline as documented in the release notes. But since the publishing issues were irregular and not always reproducible by the user or our team, we know that there are still folks who experience it. To assist our team in continuing to track down the problem, going through the linked steps I shared with Gonzalo are what'd we ask to help share a bit more information with our team. 

If you're able to gather the logs and share with our team, please feel free to send along here. 

Sjoerd de Vries

I still see this happening from time to time, but the good news is that from update 5 and later it was not annoying anymore. If it's not published I can click cancel (sometimes I have to click more than once) and then it returns to the publishing screen and I can do it again.

It looks as if the root cause of the problem is not solved, but at least is programmed now in a way it does not matter. At least not to me. Before I have to restart and reselect the publishing options.

So I agree with Ashley to check if you have the latest version.

Sjoerd de Vries

lol ;o) I have Apple Music and even Apple has a hard time, since I am very broad oriented. So I get the weirdest suggestions.

Back to topic, you can still that the issue still happens. Something is blocked in the background and I see that the folder is created, even if the progress bar is not starting. But then again, I just cancel until it comes back and start it again. Strangely it will always work after I abort it. But that was reported by others in the past as well.

Leslie McKerchie

I apologize Sjoerd. It looks like the first part of my message did not post at all.

You are right, I could see the issue happening in your example. I 'thought' I invited you to share your .story file with our support team. Most of these items are typically file or system specific, so it makes it hard for our team to replicate. If you are seeing consistency with an issue, I'd share with our team here so that we can see what's going on.

Sjoerd de Vries

The problem is that the issue is not easy to replicate. As you can see in the video after some tries it publishes and then it's fine. Last year I already provided some .story files and it was not solved. The result was that Articulate Storyline is now more stable (the cancel option now works) and it has a build in option to submit a problem and collect data. I am satisfied with the solution.

Ronald Ladley

My company just purchased Articulate Storyline (Update 7 - 1509.1408) and I too am having the same issue when trying to do a test LMS Publish with either AICC or SCORM).  Tin can api option works though.  Any suggestions, since we purchased this for the AICC and SCORM publishing options?

Thanks,

Ron Ladley
Gilead Sciences

Ashley Terwilliger-Pollard

Hi Susan,

Looks like you found a much older discussion (for Storyline 2) and I believe you're using Articulate 360? Have you already looked at enabling the network endpoints and ports listed here? That often solves the issue with being noted as "offline" and you may need to engage the help of your IT team. 

Hanging during publish and not being able to preview sound like larger issues. Can you check that you're adhering to the guidelines outlined here to prevent odd behavior? Let me know if that helps or if you're still having trouble I'd like to connect you with our Support Team