Storyline 2 freezing when I try to Publish

Hi,

I have now noticed that when I go to publish, the Publish window greys out and it just hangs. I can press the button to cancel and it asks me if I am sure, pressing Yes, just continues on hanging.

If I kill Storyline in the Task Manager, relaunch the program, and immediately publish it will work. I then make a few changes and it then hangs again.

All files are on a local drive and it was working fine until today.

any suggestions would be grateful.

190 Replies
Sjoerd de Vries

If you experience these problems you must enter a support ticket. That's the only way to get this solved. There is a beta version with enhancements, but this also has some logging, to log this issue.

I have also a support ticket open, but thus far can't reproduce it anymore, so I guess the support team may need as much input as possible.

Ashley Terwilliger

Hi Rob,

Did you see my post just above this? 

In some cases, you may find that the publishing process hangs in Articulate Storyline, or there may appear to be no progress at all. This is an erratic issue, and we're working with affected users to fix it.

In the meantime, we've improved the publishing process in the latest Storyline update. If the publishing process hangs for you, install the latest update and try again. If it persists, send us your Storyline log files for review. See below for details.

Please let us know if you need anything else. 

Kevin Thompson

I'm going to submit my log files, but also wanted to share (in case it hasn't been mentioned already) that the freezing occurs when publishing to Word as well. We often do this for SMEs to review and edit scripts, etc.

Never a problem for me after saving, closing, and reopening before publish.

Trevor White-Miller

Hi Karen, I really suffered with this issue for a long time, however I've only had it happen once in the last 2 months now. Things got 95% better when I upgraded to the very largest flash player. I also make sure I don't have a second window open also running Storyline ( if you were copying slides between SL projects). I also close down all other applications except email. In particular I don't have Adobe graphics packages , Powerpoint or Word open. Could be a working memory thing. Don't know if it will help you but maybe worth a try. 

Kathy Norton

Having just read this thread, I am really disappointed in how Articulate have responded to my logging the same issue. There are three of us here and we all have the same problem. All we received in support was the standard responses about send us a file/uninstall/install/send us log files. I know that intermittent problems are the worst to troubleshoot but it is disappointing that Articulate support do not appear to have not followed up on the practical suggestions that have been made here. Getting users who report problems to cover the same ground is frustrating and a waste of time.

 

Leslie McKerchie

Hi Kathy!

I see where you reached out to our support team via case #00598981 and were working with Wilbert.

Sorry to hear that you were disappointed, but when we are trying to narrow down an issue that we are unable to replicate it is important to get the feedback and log files from the users.

I would invite you to respond to your case with the information shared by Wilbert so that we can continue to troubleshoot and assist you.

Kevin Thompson

Just sharing an update / observation: After Storyline 2, Update 5, I had good luck with canceling out of the frozen publishing state (just by clicking "Cancel," but since Update 6 I've had to go back to Ctrl-Alt-Del and ending the task. 

Canceling the publishing process was preferable since it would allow me to save the project, if I happened to forget to save a change.  Moments ago, I tried to publish a Word version of a project, and it froze. Unable to cancel the process, I needed to manually end the task. It then published in blazing fast speed.  

 

Justin Grenier

Hey, Kevin.

What's important to remember about the Cancel option in Update 5 and later is that you'll need to allow the publishing process to continue running in the background until it finishes.  You can monitor its progress by watching the storyline.exe process in your Windows Task Manager.

Then, when the storyline.exe process becomes inactive, close the Task Manager, then the Cancel option should be available, at which point you can save, close, reopen, and publish again.

If the problem persists, this article outlines the additional steps that you'll need to try next.

Good luck with your project!

Tony Youens

I'm using SL2 in Parallels and every time I publish it just hangs. So at the moment I click cancel and try again. On the second or third attempt it publishes. 

I get the same thing at work were I'm not using Parallels. Both systems are being used on Windows 7.

Very much an irritation and slows down my workflow. 

Tony

Sjoerd de Vries

Hi Tony, did you create a ticket with Articulate? It looks like a lot of factors can be involved in the problem. Since this frustrates everyone (and I guess also support), I am sure they will be happy to assist. I experience this far less frequent and it also hardly slows down my workflow anymore.

Ashley Terwilliger

Hi Tony,

Did you review the article that Justin linked to above and confirm that you're on the latest update of Storyline 2, Update 6? 

As Sjoerd mentioned if you're still having difficulty after going through the above, you're welcome to connect with our Support team here and they'll be able to gather a bit more information. 

Gonzalo Rosetti

I am using SL2 Update 7 (on Parallels Desktop 11) and the problem persists ... after so many months and posts of complain.

It is basically the same old story: when I hit "publish", SL hangs and does not publish.

I shut SL2 down and reopened the file. Hit "publish" and it did.

Any ideas how to avoid this?

Josh Uhlig

Anytime I have Storyline open for more than 5 minutes and I need to publish, I close the program and re-open the presentation before publishing.  It's a bit annoying, but takes less than 30 seconds.  It's better (and less time consuming) than clicking publish, having it freeze,  clicking cancel, and hope that it unfreezes so I can close the program without using the Windows Task Manager.

I've never had an issue if I close the application fully (not just the presentation) and then immediately publish upon re-opening.

Gonzalo Rosetti

Hi Ashley,

I can see it has been an issue difficult to deal with. I am using Update 7, and the issue persists.

I actually mentioned in my previous post I followed the steps you suggested (I closed and reopened SL2) and managed to publish. However, that is not the way it worked in SL1.

I tried to collect the logs (suggested in step 3), I have run the file as an admin but no zip file has been generated on the desktop. (Neither on Parallels Desktop (PD11) nor the Mac desktop).