Storyline 2 freezing when I try to Publish

Hi,

I have now noticed that when I go to publish, the Publish window greys out and it just hangs. I can press the button to cancel and it asks me if I am sure, pressing Yes, just continues on hanging.

If I kill Storyline in the Task Manager, relaunch the program, and immediately publish it will work. I then make a few changes and it then hangs again.

All files are on a local drive and it was working fine until today.

any suggestions would be grateful.

190 Replies
Michael Hardin

Has there been any progress on correcting this bug?

I am having the same exact issue, even after installing Update 3.  The most frustrating aspect is you never know when it is going to happen.  I can publish fine a few times and then the next time I encounter the issue exactly as shown in Will's screencast (on page 1).  Usually, after using Task Manager to kill Storyline and restarting it, the next time it publishes fine. Also, it seems like I can go days without the issue and then encounter it numerous times within the same day.

I have noticed that when this happens, publishing is initiated, as the publishing folder is cleared and begins to populate with a few files and folders, but then everything just freezes. 

Ashley Terwilliger

Hi Michael,

Have you run through the other troubleshooting steps in this thread? I know that a few users have submitted support cases and looking at those, it seems the issue is not consistently reproducible (as you said) so we'd be happy to take a look at one of your files and if you could share any more information about your set up (Windows version, publish location, other programs running, SL1 files being upgraded or just new SL2 or both, etc.) that would help us further track down this issue. 

Michael Hardin

Hi Ashley,

Yes, I've run through the troubleshooting steps, without resolution.  To answer your questions, it happens with new, as well as, upgraded SL1 projects.  I am using Windows 7 (64 bit) and publishing on the C drive in the "My Articulate Projects" folder.  I usually have Outlook and Word running, but no matter what I have running, after killing and reopening Storyline (without changing anything else) it publishes fine.

Sara Swier

The same often happens to me too, exactly as explained by many others; when I try to publish a project, it often freezes. Nothing helps but killing it via the Task Manager and reopening the file to try it again. I am publishing the course to my desktop and have tried the options to uninstall-reinstall storyline 2, as well as downloading the latest update (which resulted in uninstalling-reinstalling again).

It would be great if a next update could fix this freezing-while-publishing-problem.

Ashley Terwilliger

Hi Sara, 

Have you already looked at and gone through the other troubleshooting steps here in terms of working locally, ensuring you're publishing to a local file path that is under 260 characters and a file name without any special characters, accents, etc., conducting the detailed repair here? 

I've checked into the cases mentioned here, and it does not seem that there is a common pattern to them, but we'd be happy to check one of your files to see how it publishes on our end. You're welcome to share a .story file here or send it along to us here. 

Will Findlay

Ashley... it sounds from your responses like Articulate cannot reproduce this problem. Can I just throw it out there that I this may nothing to do with a particular Storyline file someone is working on? It seems like an issue that is not file specific, but rather is machine/OS specific. So sending you a .story file seems kind of pointless.

Trevor White-Miller

Following on from Will, I still don't understand how Articulate haven't run into the same issue during their own testing process.

Even if it is not a articulate file/software issue there is something very common in users computers which does not like publishing with Storyline 2 and needs to be addressed.  

There is a critical mass of users with this problem in this tread alone, so I would like to suggest that Articulate write a series of survey questions to collect relevant information about operating systems, ram, dish space, version no, other related info like steps prior to publishing etc (and  anything that Articulate think may impact the publishing process) and send them to all of us in the thread to complete. I'm sure there must be a pattern within the users, or something we have that the Articulate test platform does not.

As Will said there is little point in sending in problem files. In my case it occurs whenever I change the publish options the first time before I publish in full. Once I've had one failure on the first publish the problem goes away for that file.    

Ashley Terwilliger

Hi Will and Trevor, 

You're correct - we haven't been able to reproduce it yet, so we always like to start with a file to see if it's something file specific. Will, I was relooking at your screencast, and noticed there was a backslash in the course title.  By Microsoft's definition, it's a prohibited character within file names, which is what we use in terms of Storyline file names, paths, etc. 

If the file publishes fine for our team, than working through a support case will allow us to take a look at more system specs. 

Kevin Thompson

Hi all,

For me, the publishing problem never occurs immediately after opening a file.  It is always after doing a fair amount of work in a file, making a lot of timeline adjustments, several previews, etc.  So when trying to reproduce this problem, be sure to simulate that type of workflow by having the file open for a good amount of time. 

I just published 4 narrated projects, one after the other (without closing Storyline), with no problems at all. But I would bet that if I would stop and work for a good while in one of them that the publishing process would hang immediately, requiring Task Manager > End Task.  

Still love the product, but looking forward to a fix for this!  Thanks!

Will Findlay

It is actually forward slash in the title : "Permission/Assent in Clinical Research"

But note, this is the TITLE of presentation, not the filename. I would assume the Title of a presentation can have any characters in it you want.

I just tested to make sure, and Storyline allows you to put a "/" in your course title. When you publish/save the file it takes the forward slashes out of the title to create the folder name/file name.

For example, if I title my presentation like this: Is/This/A/Problem/To/Have/So/Many/Forward/Slashes

And then I Publish it (or save it), Storyline removes all of the forward slashes.: IsThisAProblemToHaveSoManyForwardSlashes.story

So I doubt it has anything to do with filenames. I really appreciate that you are engaging with us on this problem. But I kind of get the impression that somebody up the chain has some kind of hard line rule that unless it can be reproduced at Articulate, the customer must be doing something wrong.

 

 

 

Sjoerd de Vries

I agree. After re-installing the problem on my side seems to occur less frequent, but still is there. My case is closed, after I got questions like "can you rebuild your course, etc..". It happens unpredicably with new and older content and is consistent with other stories here and on LinkedIn discussions. I just gave up and really hope Articulate finds out the root cause and solves this.

 

Ashley Terwilliger

Hi Will,

Forward (or backward) slashes aren't prohibited in course titles, and as you mentioned they're removed in the file name during the publish process. It may be worth publishing without it though to see if that helps any of the odd publishing behavior: start with a clean file, short file name and title that doesn't include anything besides alpha numeric characters, check the file path, etc. Just some ideas to help isolate the issue further as our team continues to look into it. 

Hi Sjoerd, 

I see that you have a case with Jayem, that is still set to open based on his most recent email on Dec 8,  where he asked for:

I understand that the problem persists. To help us diagnose this issue, please upload the Articulate Storyline 2 error logs from your computer for us to review. Here's 

how:http://www.articulate.com/support/storyline-2/how-to-upload-articulate-storyline-2-error-logs-to-articulate-support 

We would also like to request some Windows Event log files. Please manually gather and zip the following files: 

%SystemRoot%\System32\Winevt\Logs\OAlerts.evtx 
%SystemRoot%\System32\Winevt\Logs\ODiag.evtx 
%SystemRoot%\System32\Winevt\Logs\OSession.evtx 
%SystemRoot%\System32\Winevt\Logs\Application.evtx 
%SystemRoot%\System32\Winevt\Logs\HardwareEvents.evtx 
%SystemRoot%\System32\Winevt\Logs\Internet Explorer.evtx 
%SystemRoot%\System32\Winevt\Logs\System.evtx 

It's OK if the you're unable to locate some of these files. Here's a Screenr video on how to locate the log files: 
https://articulatesupport.viewscreencasts.com/53427c7f50a94274a5bf29006666bc13 

Here's a Screenr video on how to create a ZIP file of the log files: 
https://articulatesupport.viewscreencasts.com/54916834aa8c4de6a04501228e447c79 

Please attach the zipped evtx files in your reply. 

If you're able to gather those documents and reply to him (or start a new case and reference case number 00440582) we'll be able to continue to take a look. 

Ashley Terwilliger

Hi Sjoerd, 

Thanks for the update - and repairing Storyline or uninstalling Storyline is one of the methods previously mentioned here - that for some other users also resolved the behavior. We also released Storyline 2 Update 4 on Friday which dealt with a few saving errors - so it may be worth ensuring you're on the newest update as well. 

Sjoerd de Vries

You better can create a ticket with Storyline. You may need to re-install .net framework 4, flash (with a de-installer), Storyline (with a registry removal tool) and then re-install everything as an administrator (right-click the installers and select "as administrator" or better with UAC off. The helpdesk can help you with that.

At least it seems to be solved on my side.

 

Michael O.

I have a duel monitor workstation and have noticed that if I have multiple application windows open and am publishing in Storyline it looks like things are grayed out and nothing is happening.  It turns out the publishing dialog box is  hidden behind other window displays.  If I close them, I then see the Storyline Dialog box and all I have to do is click on an OKAY button.