What we’re doing to help you update your courses for browser auto-play settings (updated 12/06/2018)

Recently some common browsers, including Chrome and Safari, have started blocking auto-play of audio and video content on the sites you visit. That includes audio and video in e-learning courses that are hosted online.

That means that audio or video on the first slide of a course will not automatically play. It also means that videos and audio won’t work when learners suspend a course and restart on a slide that contains audio or video. Your content won’t be affected by this issue unless videos and audio are set to play automatically.

Unfortunately there’s nothing you can do to override the browser’s settings. That’s why we released updates for Storyline 360, Studio 360, Storyline 3, and Storyline 2 to automatically detect when this occurs and present the learner with a play button overlay. That user interaction is what the browser needs in order to play the audio or video. If your courses have a required user interaction on the first slide and no media, you may not need to republish to have the media autoplay.

We’re working on a content updater for Storyline 360, Studio 360, Storyline 3, Storyline 2 and Studio '13 that’ll let you mass update all your courses. In the meantime, you’ll need to republish your courses one at a time to fix this issue.

We know this is super frustrating, and we’re so sorry for the trouble. We’ll keep you posted on our progress.

UPDATE (12/06/2018): We've now created a tool that lets you mass update existing courses without republishing them. Currently, the updater works on Storyline 360, Storyline 3, Studio 360, Storyline 2, and Studio '13 courses. See this article for details!

165 Replies
sebastjan f

problem occurs if you have audio on the first (starting) slide. All other slides work fine.

My solution:

- add a blank dummy first page and add "Jump to #your original first slide# when timeline starts" trigger.

Probably causing some delay and influencing user experience.. but at least it is working.

To the Storyline team:

- we need some sort of "batch update" .. just checked - we have over 1100 *.story files.. republishing is not my favorite option :(

 

Colin Davis

I can't reproduce the problem to test the content.  I've changed the Autoplay policy to "Document user activation is required" and I've even tried launching Chrome with chrome.exe --disable-features=PreloadMediaEngagementData,AutoplayIgnoreWebAudio,MediaEngagementBypassAutoplayPolicies as suggested in https://developers.google.com/web/updates/2017/09/autoplay-policy-changes but my courses still keep playing fine.

Is it because they are playing the Flash version of the content (I still use Storyline 2)?

Or is it because Google says: Autoplay with sound is allowed if: User has interacted with the domain (click, tap, etc.) - so in my case the user has clicked Launch which opens a new window to play the content which is hosted in the same domain?

I need more information on the issues so that we can plan our response for October please.

Ashley Terwilliger

Hi Colin,

If you look at the end of your course URL, you can determine if it's Flash or HTML5. The flash output would end in story.html vs. the HTML5 which would end with story_html5.html. If you're hosting in an LMS, that may be using it's own URL and could mask that ending. 

Storyline 2 did receive an update to account for this issue with autoplay as well, and Storyline 2 customers were emailed about it on Friday. You can also find the download link for the latest update here. 

The launch button may be enough to count toward Google's autoplay policies, or it may be that you've previously launched content from that page enough times that Google considers you want media to autoplay. Another way to test that is to use a Chrome incognito browser. 

sebastjan f

Just to clarify:

- your solution is to automatically add the play button (attached printscreen) in front of all content (if and when you detect that content has audio on first slide)? I am getting this screen on Firefox (I know unsupported platform... but still - content works)

- can you make it customizable (design wise).. or at least same design as iPad/tablet (black background)?

Why dont you "fake" player/export and add a blank page at the beginning of the course (see my workaround above).

Forcing users to click a play button which can not be designed is not my favorite solution.. it leads to a bad user experience - especially if storyline content is opened in iframe which is just a small part of the content.

Colin Davis

The URL of the page is hidden by the LMS launch page.  The easiest way of seeing whether you get the Flash or the HTML5 version is to right mouse click on the content.  No pop-up=HTML5, if you get a pop-up saying "About Adobe Flash Player ...." as the bottom option, then it's Flash.

I know about the "fix" but that means re-publishing hundreds of courses!  Not an option.  So I want to reproduce the issue on the current content that is on my LMS so that I can evaluate the size of the problem and give our support team an answer prior to October.

Right now, I can't make any of my courses fail so I can't see what the issue will be.

Leslie McKerchie

Hey Jen,

Sorry to hear that you've run into an issue with the download. I just took a look and was able to both download and install the update.

  • Are you using the link shared on this page for Storyline 2?
  • Are you getting an error or some sort?
  • Can you try the process in a different browser?

Just let me know your findings and I'd be happy to continue helping you out here.

Marie DesJardin

Thank you for looking into the Google autoplay failure.

I just completed 2 projects with 15 modules, and they all behave the same way. I will try to attach one of the Story files for you to look at. My company’s server might strip it out; please confirm if you receive the file - VMSintro-Articulate-MD.story

I’m also attaching a png showing the versions of SL3 and Google I’m running.
I’m attaching an MP4 so you can see what I see when each of these modules launches. The first slide is silent unless I click the slidebar. Audio begins automatically on page 2.

Thank you!

Leslie McKerchie

Oh no, Marie. Looks like you may be replying via e-mail, so we got your signature, but no files.

Be sure to pop into the forums via 'View' when you get your e-mail notification and share it with us directly here.

You can also remove your signature if needed by clicking ‘Edit’ beneath your previous response here. Here’s a quick Peek video if you need help.