A video cannot be inserted from this embed code.

Update: I still have SL1 on my machine so I copied a code SL2 rejected, and SL1 took it with no problem.  I really need to figure this out.

----

Can anyone tell me what the requirements are for an embed code? We're using the same videos on the same servers that we've been using for years. In SL1, no worries--we used the embed codes from our media server and had no trouble. Before we switched to SL2, I tested out the video feature to make sure we could embed the same way we always did, with no trouble. As of a couple of weeks ago, I could.

 

Here's an example of a video I embedded a couple of weeks ago that worked fine:

 

<iframe src="https://w.kontiki.com/laquinta/player/2f1eddaf-fd6f-4d0e-886e-42a0d0b49df6?params=MD10cnVlOzE9NTM7MTI9dHJ1ZQ==" style="border:none;width:100%;height:100%" scrolling='no' allowfullscreen></iframe>

 

NOW, when i go and try THAT VERY code, I get this message:

A video cannot be inserted from this embed code. Verify that the embed code is correct and try again. 

What changed from a couple of weeks ago? I recommended SL2 and we upgraded based on many tests, including embedded video. There is simply no reason it shouldn't work today.

 

 

 

 

 

 

 

 

131 Replies
Jennifer Shafley

I am having a similar issue.  I am unable to embed YouTube videos using the "insert video from website" feature in Storyline 2.  I did install the latest update with the same results.

I have tried several modifications to the code based on this feed and none of the iterations are working for me.

A couple that I have tried are...

<iframe src="https://www.youtube.com/embed/TE9TpraPlrE?embed=true&wide=true" frameborder="0" height="261" width="348" allowfullscreen=""></iframe>

<iframe width="640" height="360" src="https://www.youtube.com/embed/TE9TpraPlrE?rel=0&amp;controls=0&amp;showinfo=0" frameborder="0" allowfullscreen></iframe>

I have tried a variety of YouTube videos from a variety of publishers and the issue has been consistent.

 

 

Ashley Terwilliger

Hi Jennifer, 

YouTube videos that were added to Articulate content via Insert > Video > Video from Website aren't currently working.

You'll see this message where your videos should be:

YouTube is upgrading to a newer version, which is not supported by this device or app. To learn more and see where you can watch YouTube, visit www.youtube.com/devicesupport

Google changed support for the YouTube API, which prevents videos added in this manner from playing in Articulate content. We've asked Google to reconsider their decision (Google Data Issue 7146).

In the meantime, we recommend adding YouTube videos as web objects instead. As an added benefit, YouTube web objects are supported in Flash, HTML5, and Articulate Mobile Player output.

Fiona Mariner

Hi, I'm aware of the issue with YouTube video embedding, but this morning I went looking for a work-around ahead of a training session tomorrow and found that I wasn't having any luck embedding videos from any of the sites I tried.

This is an embed code from National Geographic: 

<iframe src="//assets.nationalgeographic.com/modules-video/assets/ngsEmbeddedVideo.html?guid=1f9320a8-866a-415a-ab2a-6910c64fa337" width="640" height="365" frameborder="0" seamless="seamless" scrolling="no" allowFullScreen></iframe>

...and this is the error message:

This is another one from Animal Planet:

<iframe width="512" height="288" src="http://www.discovery.com/?post_type=video&p=67636" frameborder="0" scrolling="no" mozallowfullscreen webkitallowfullscreen allowfullscreen></iframe>

.... and this is what appears on screen (in this case you can see a web page with live links):

I've tried Vimeo too without any success.

This is after downloading and installing Update 5 - has something changed as a result of the update?

 

Ashley Terwilliger

Hi Fiona, 

Thanks for sharing those here - and I'd be curious if you could share the direct link to the National Geographic video? I see the same behavior you're showing with these, but I don't think it's a change in Update 5, even though there was a fix for embed code that didn't include dimensions. 

Fiona Mariner

Hi Ashley, I confess I didn't get as far as publishing - since I can usually view videos without difficulty in edit/preview mode!

I'm only getting a black screen in the second slide of your published project so if it's working for you then maybe it's an issue with my software / server settings.

 

Ashley Terwilliger

Hi Fiona, 

Hm, can you check which version numbers you're using? You can either go to the "About Chrome/Firefox" from the browser settings to see or use a site such as supportdetails.com which will gather that information within your particular browser. 

I tested it again - and was still able to open and play the video. I'm in Chrome version 43. 

Ashley Terwilliger

Hi Jared,

Fiona's issue is a bit different, as that was a YouTube video embedded as a web object. There is a known issue right now with inserting YouTube videos as described here based on how they changed their API code.  As you'll see in that article, we've asked them to revert that change, and in the meantime you can insert YouTube videos as web objects. If you run into any problems with the web object set up please let us know. 

Dom Sweeten

We are having trouble with this too.

SL1 - insert video from website works fine

example embed code:

<iframe width="853" height="480" src="https://www.youtube.com/embed/L-DTNRoL95o?rel=0&amp;showinfo=0" frameborder="0" allowfullscreen></iframe>

SL2 however returns message (using same embed code):

A video cannot be inserted from this embed code. Verify that the embed code is correct and try again.

As it works in SL1 and not in SL2 it indicates this is not a firewall issue.

Any advice please?

 

ant carter

I am having problem embedding a youtube video in AS2. The embed code is:

<iframe width="854" height="510" src="https://www.youtube.com/embed/_UKLncvGxQ8?list=PLBF382935FA9ACB9A" frameborder="0" allowfullscreen></iframe>

Like those above - I am able to insert it in AS1, but not in AS2. Do I really need to use the workaround above to solve this issue - surely this - as it is a bug - can be dealt with and updates issued??

ant

Ashley Terwilliger

Hi Ant,

We've updated our documentation in regards to inserting YouTube videos to use the web object method vs. embedding the code based on the change as of May 2015, in which Google no longer allows YouTube videos to be embedded in this manner. However, YouTube videos in existing courses will continue to work.

You can still add YouTube videos to new projects using web objects, and they'll work in Flash, HTML5, and Articulate Mobile Player output.